# CVE-2020-36830: nescalante urlregex Backtracking index.js redos

> Remote attackers can cause denial of service via inefficient regular expression complexity in the urlregex library.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Sep 2024
- **Updated:** 3 Sep 2024
- **Also known as:** GHSA-rw72-v6c7-hf9r

## What is CVE-2020-36830?

CVE-2020-36830 is a medium-severity denial of service vulnerability in nescalante urlregex, published on 2 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was found in nescalante urlregex up to 0.5.0 and classified as problematic. This issue affects some unknown processing of the file index.js of the component Backtracking. The manipulation leads to inefficient regular expression complexity. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.5.1 is able to address this issue. The identifier of the patch is e5a085afe6abfaea1d1a78f54c45af9ef43ca1f9. It is recommended to upgrade the affected component.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2020-36830?

2 open source packages ship an affected version, including urlregex. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `urlregex` | npm | All versions | 0.5.1 |
| `urlregex` | npm | All versions | 0.5.1 |

Products: Nescalante Urlregex.

## How do I fix CVE-2020-36830?

Upgrade urlregex to 0.5.1 or later.

## Is CVE-2020-36830 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-36830 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36830 and fix it if it is affected.

What it is: CVE-2020-36830 is a medium-severity denial of service vulnerability in nescalante urlregex, published on 2 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-36830 exists.

Affected packages and fixed versions:
- urlregex (npm): affected all versions; fixed in 0.5.1
- urlregex (npm): affected all versions; fixed in 0.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36830/ (Markdown: https://insights.sbomify.com/CVE-2020-36830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36830
- OSV: https://osv.dev/vulnerability/CVE-2020-36830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36830/
Summaries are generated and may contain mistakes; the official description above is the record.
