# CVE-2020-36843: Ed25519 Signature Malleability in ed25519-java Due to Missing Scalar Range Check

> Attackers can generate alternative valid signatures for known messages due to signature malleability in the EdDSA-Java library, bypassing strict signature verification.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Mar 2025
- **Updated:** 18 Mar 2025
- **Also known as:** AZL-73250, CLSA-2026-1770682157, DEBIAN-CVE-2020-36843, GHSA-p53j-g8pw-4w5f, MINI-65fc-pwc9-fjh6, MINI-mqwq-7r2q-x4rp, MINI-qvjx-q843-qhm7, MINI-rxc8-vx2f-w77j, MINI-w353-hhqg-f5vm, MINI-x4v6-2mrj-mhf2, OESA-2025-1334, SUSE-SU-2025:1029-1, UBUNTU-CVE-2020-36843, openSUSE-SU-2025:14892-1

## What is CVE-2020-36843?

CVE-2020-36843 is a medium-severity vulnerability in str4d ed25519-java, published on 13 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The implementation of EdDSA in EdDSA-Java (aka ed25519-java) through 0.3.0 exhibits signature malleability and does not satisfy the SUF-CMA (Strong Existential Unforgeability under Chosen Message Attacks) property. This allows attackers to create new valid signatures different from previous signatures for a known message.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2020-36843?

4 open source packages ship an affected version, including net.i2p.crypto:eddsa and net.i2p:i2p.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net.i2p.crypto:eddsa` | Maven | All versions to 0.3.0 | None |
| `net.i2p.crypto:eddsa` | Maven | All versions to 0.3.0 | None |
| `net.i2p:i2p` | Maven | All versions | 0.9.39 |
| `net.i2p:i2p` | Maven | All versions | 0.9.39 |
| `ed25519-java` | SUSE:Enterprise Storage 7.1 | All versions | 0.3.0-150200.5.9.1 |
| `ed25519-java` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 0.3.0-150200.5.9.1 |
| `ed25519-java` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 0.3.0-150200.5.9.1 |
| `ed25519-java` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 0.3.0-150200.5.9.1 |
| `ed25519-java` | SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 0.3.0-150200.5.9.1 |
| `ed25519-java` | SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 0.3.0-150200.5.9.1 |
| `ed25519-java` | SUSE:Linux Enterprise Module for Development Tools 15 SP6 | All versions | 0.3.0-150200.5.9.1 |
| `ed25519-java` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 0.3.0-150200.5.9.1 |
| `ed25519-java` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 0.3.0-150200.5.9.1 |
| `ed25519-java` | SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 0.3.0-150200.5.9.1 |
| `ed25519-java` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 0.3.0-150200.5.9.1 |
| `ed25519-java` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 0.3.0-150200.5.9.1 |
| `ed25519-java` | SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 0.3.0-150200.5.9.1 |
| `ed25519-java` | openSUSE:Leap 15.6 | All versions | 0.3.0-150200.5.9.1 |
| `ed25519-java` | openSUSE:Tumbleweed | All versions | 0.3.0-6.1 |

## How do I fix CVE-2020-36843?

Upgrade to a fixed version.

## Is CVE-2020-36843 being exploited?

There is no known exploitation of CVE-2020-36843 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-36843 and fix it if it is affected.

What it is: CVE-2020-36843 is a medium-severity vulnerability in str4d ed25519-java, published on 13 Mar 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-36843 in the wild and no public exploit code.

Affected packages and fixed versions:
- net.i2p.crypto:eddsa (Maven): affected all versions up to 0.3.0; no fix listed
- net.i2p.crypto:eddsa (Maven): affected all versions up to 0.3.0; no fix listed
- net.i2p:i2p (Maven): affected all versions; fixed in 0.9.39
- net.i2p:i2p (Maven): affected all versions; fixed in 0.9.39

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-36843/ (Markdown: https://insights.sbomify.com/CVE-2020-36843/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-36843
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-36843
- OSV: https://osv.dev/vulnerability/CVE-2020-36843

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-36843/
Summaries are generated and may contain mistakes; the official description above is the record.
