CVE-2020-3717 Magento Path Traversal
Attackers can exploit a path traversal flaw in Magento to access sensitive information, requiring administrators to upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-3717?
CVE-2020-3717 is a medium-severity path traversal vulnerability in Magento Magento, published on 29 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Magento versions 2.3.3 and earlier, 2.2.10 and earlier, 1.14.4.3 and earlier, and 1.9.4.3 and earlier have a path traversal vulnerability. Successful exploitation could lead to sensitive information disclosure.
Weakness: CWE-22
Which versions are affected by CVE-2020-3717?
5 open source packages ship an affected version, including magento/community-edition and magento. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | From 2.2.0 | 2.2.11 |
magento/community-edition Packagist | From 2.2.0 | 2.2.11 |
magento/community-edition Packagist | From 2.3.0 | 2.3.4 |
magento/community-edition Packagist | From 2.3.0 | 2.3.4 |
magento Bitnami | From 2.2.0 | 2.2.11, 2.3.4 |
Products include Magento Magento.
How do I fix CVE-2020-3717?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.11 or 2.3.4.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2020-3717 being exploited?
There is no known exploitation of CVE-2020-3717 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2020-3717, GHSA-874g-pxqp-frqp.