CVE-2020-3718 Magento security bypass vulnerability
Attackers can bypass security features in Magento to achieve arbitrary code execution, requiring immediate upgrades.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-3718?
CVE-2020-3718 is a critical vulnerability in Magento Magento, published on 29 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Magento versions 2.3.3 and earlier, 2.2.10 and earlier, 1.14.4.3 and earlier, and 1.9.4.3 and earlier have a security bypass vulnerability. Successful exploitation could lead to arbitrary code execution.
Which versions are affected by CVE-2020-3718?
7 open source packages ship an affected version, including magento/community-edition, magento and magneto/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.2.11 |
magento/community-edition Packagist | All versions | 2.2.11 |
magento/community-edition Packagist | From 2.3.0 | 2.3.4 |
magento/community-edition Packagist | From 2.3.0 | 2.3.4 |
magento Bitnami | From 2.2.0 | 2.2.11, 2.3.4 |
magneto/core Packagist | All versions | 1.9.4.4 |
1 more packages
magneto/core Packagist | All versions | 1.9.4.4 |
Products include Magento Magento.
How do I fix CVE-2020-3718?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.11 or 2.3.4.
Is CVE-2020-3718 being exploited?
There is no known exploitation of CVE-2020-3718 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2020-3718, GHSA-x9p7-vgp2-9pq2.