CVE-2020-3719 Magento sql injection vulnerability
Attackers can exploit SQL injection in Magento to disclose sensitive information, requiring immediate upgrades for e-commerce operators.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-3719?
CVE-2020-3719 is a high-severity SQL injection vulnerability in Magento Magento, published on 29 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Magento versions 2.3.3 and earlier, 2.2.10 and earlier, 1.14.4.3 and earlier, and 1.9.4.3 and earlier have an sql injection vulnerability. Successful exploitation could lead to sensitive information disclosure.
Weakness: CWE-89
Which versions are affected by CVE-2020-3719?
7 open source packages ship an affected version, including magento/community-edition, magento and magento/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.2.11 |
magento/community-edition Packagist | All versions | 2.2.11 |
magento/community-edition Packagist | From 2.3.0 | 2.3.4 |
magento/community-edition Packagist | From 2.3.0 | 2.3.4 |
magento Bitnami | From 2.2.0 | 2.2.11, 2.3.4 |
magento/core Packagist | All versions | 1.9.4.4 |
1 more packages
magento/core Packagist | All versions | 1.9.4.4 |
Products include Magento Magento.
How do I fix CVE-2020-3719?
Upgrade magento/community-edition to a fixed version for your release line: 2.2.11 or 2.3.4.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2020-3719 being exploited?
There is no known exploitation of CVE-2020-3719 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2020-3719, GHSA-rr59-pjwj-6grj.