# CVE-2020-3719: Magento sql injection vulnerability

> Attackers can exploit SQL injection in Magento to disclose sensitive information, requiring immediate upgrades for e-commerce operators.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-magento-2020-3719, GHSA-rr59-pjwj-6grj

## What is CVE-2020-3719?

CVE-2020-3719 is a high-severity SQL injection vulnerability in Magento Magento, published on 29 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Magento versions 2.3.3 and earlier, 2.2.10 and earlier, 1.14.4.3 and earlier, and 1.9.4.3 and earlier have an sql injection vulnerability. Successful exploitation could lead to sensitive information disclosure.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2020-3719?

7 open source packages ship an affected version, including magento/community-edition, magento and magento/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | 2.2.11 |
| `magento/community-edition` | Packagist | All versions | 2.2.11 |
| `magento/community-edition` | Packagist | From 2.3.0 | 2.3.4 |
| `magento/community-edition` | Packagist | From 2.3.0 | 2.3.4 |
| `magento` | Bitnami | From 2.2.0 | 2.2.11, 2.3.4 |
| `magento/core` | Packagist | All versions | 1.9.4.4 |
| `magento/core` | Packagist | All versions | 1.9.4.4 |

Products: Magento Magento.

## How do I fix CVE-2020-3719?

Upgrade magento/community-edition to a fixed version for your release line: 2.2.11 or 2.3.4.

## Is CVE-2020-3719 being exploited?

There is no known exploitation of CVE-2020-3719 in the wild and no public exploit code.

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-3719 and fix it if it is affected.

What it is: CVE-2020-3719 is a high-severity SQL injection vulnerability in Magento Magento, published on 29 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-3719 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; fixed in 2.2.11
- magento/community-edition (Packagist): affected all versions; fixed in 2.2.11
- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.4
- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.4
- magento (Bitnami): affected from 2.2.0; fixed in 2.2.11, 2.3.4
- magento/core (Packagist): affected all versions; fixed in 1.9.4.4
- magento/core (Packagist): affected all versions; fixed in 1.9.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-3719/ (Markdown: https://insights.sbomify.com/CVE-2020-3719/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-3719
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-3719
- OSV: https://osv.dev/vulnerability/CVE-2020-3719

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-3719/
Summaries are generated and may contain mistakes; the official description above is the record.
