# CVE-2020-37267: Renovate 19.180.0 before 23.25.1 Token Leakage via Logs

> Attackers with log access can steal Renovate bot credentials when using Azure DevOps, potentially leading to unauthorized repository access.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** GHSA-36rh-ggpr-j3gj, GHSA-w8hm-jrh2-57j3

## What is CVE-2020-37267?

CVE-2020-37267 is a high-severity vulnerability in renovatebot renovate, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Renovate versions >=19.180.0 and <23.25.1, when used with Azure DevOps, may expose the bot's authorization token in server or pipeline logs because the git http.extraheader=AUTHORIZATION parameter is logged without redaction. Anyone with access to saved logs could obtain the bot credentials. Fixed in 23.25.1; Azure DevOps users should revoke and regenerate credentials if logs may have been exposed.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2020-37267?

2 open source packages ship an affected version, including renovate.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `renovate` | npm | From 19.180.0 | 23.25.1 |
| `renovate` | npm | From 19.180.0 | 23.25.1 |

## How do I fix CVE-2020-37267?

Upgrade renovate to 23.25.1 or later.

## Is CVE-2020-37267 being exploited?

There is no known exploitation of CVE-2020-37267 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-37267 and fix it if it is affected.

What it is: CVE-2020-37267 is a high-severity vulnerability in renovatebot renovate, published on 19 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-37267 in the wild and no public exploit code.

Affected packages and fixed versions:
- renovate (npm): affected from 19.180.0; fixed in 23.25.1
- renovate (npm): affected from 19.180.0; fixed in 23.25.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-37267/ (Markdown: https://insights.sbomify.com/CVE-2020-37267/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-37267
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-37267
- OSV: https://osv.dev/vulnerability/CVE-2020-37267

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-37267/
Summaries are generated and may contain mistakes; the official description above is the record.
