{"answers":{"affected":"2 open source packages ship an affected version, including vyper.","exploited":"There is no known exploitation of CVE-2020-37286 in the wild and no public exploit code.","fix":"Upgrade vyper to 0.2.6 or later.","what":"CVE-2020-37286 is a high-severity vulnerability in vyperlang vyper, published on 21 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2020-37286 and fix it if it is affected.\n\nWhat it is: CVE-2020-37286 is a high-severity vulnerability in vyperlang vyper, published on 21 Oct 2026. \nExploitation: There is no known exploitation of CVE-2020-37286 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vyper (PyPI): affected all versions; fixed in 0.2.6\n- vyper (PyPI): affected all versions; fixed in 0.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-37286/ (Markdown: https://insights.sbomify.com/CVE-2020-37286/index.md)","id":"CVE-2020-37286","markdown":"https://insights.sbomify.com/CVE-2020-37286/index.md","name":"CVE-2020-37286","record":{"aliases":["GHSA-2r3x-4mrv-mcxf","GHSA-3w56-2qv9-5m4p"],"analysis":null,"analysis_generated_by":null,"assigner":"VulnCheck","cpe":[],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"Vyper from 0.1.0b4 before 0.3.0 contains a memory corruption vulnerability caused by an incorrect stack tip pointer when internal function calls appear inside tuples or nested calls. Contracts using such calls as tuple elements, call arguments, or builtin arguments like concat or ecrecover can return corrupted values or pass wrong arguments to external calls.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Vyper 0.1.0b4 before 0.3.0 Memory Corruption via Nested Internal Function Calls","id":"CVE-2020-37286","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Vyper before 0.2.6 Call Stack Corruption via Complex Type Function Arguments","id":"CVE-2020-37287"},"packages":[{"ecosystem":"PyPI","fixed":["0.2.6"],"introduced":["0"],"last_affected":[],"package":"vyper","purl":null,"source":"GHSA-2r3x-4mrv-mcxf"},{"ecosystem":"PyPI","fixed":["0.2.6"],"introduced":["0"],"last_affected":[],"package":"vyper","purl":"pkg:pypi/vyper","source":"GHSA-2r3x-4mrv-mcxf"}],"prev":{"headline":"Sickbeard build-507 Reflected XSS via testNaming pattern Parameter","id":"CVE-2020-37284"},"products":["vyper"],"published":"2026-10-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-27","vendors":["vyperlang"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2020-37286/"}