# CVE-2020-37286: Vyper 0.1.0b4 before 0.3.0 Memory Corruption via Nested Internal Function Calls


- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** GHSA-2r3x-4mrv-mcxf, GHSA-3w56-2qv9-5m4p

## What is CVE-2020-37286?

CVE-2020-37286 is a high-severity vulnerability in vyperlang vyper, published on 21 Oct 2026. 

### Official description

Vyper from 0.1.0b4 before 0.3.0 contains a memory corruption vulnerability caused by an incorrect stack tip pointer when internal function calls appear inside tuples or nested calls. Contracts using such calls as tuple elements, call arguments, or builtin arguments like concat or ecrecover can return corrupted values or pass wrong arguments to external calls.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2020-37286?

2 open source packages ship an affected version, including vyper.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.2.6 |
| `vyper` | PyPI | All versions | 0.2.6 |

## How do I fix CVE-2020-37286?

Upgrade vyper to 0.2.6 or later.

## Is CVE-2020-37286 being exploited?

There is no known exploitation of CVE-2020-37286 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-37286 and fix it if it is affected.

What it is: CVE-2020-37286 is a high-severity vulnerability in vyperlang vyper, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2020-37286 in the wild and no public exploit code.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.2.6
- vyper (PyPI): affected all versions; fixed in 0.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-37286/ (Markdown: https://insights.sbomify.com/CVE-2020-37286/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-37286
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-37286
- OSV: https://osv.dev/vulnerability/CVE-2020-37286

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-37286/
Summaries are generated and may contain mistakes; the official description above is the record.
