{"answers":{"affected":"2 open source packages ship an affected version, including vyper.","exploited":"There is no known exploitation of CVE-2020-37287 in the wild and no public exploit code.","fix":"Upgrade vyper to 0.2.6 or later.","what":"CVE-2020-37287 is a high-severity vulnerability in vyperlang vyper, published on 21 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2020-37287 and fix it if it is affected.\n\nWhat it is: CVE-2020-37287 is a high-severity vulnerability in vyperlang vyper, published on 21 Oct 2026. \nExploitation: There is no known exploitation of CVE-2020-37287 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vyper (PyPI): affected all versions; fixed in 0.2.6\n- vyper (PyPI): affected all versions; fixed in 0.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-37287/ (Markdown: https://insights.sbomify.com/CVE-2020-37287/index.md)","id":"CVE-2020-37287","markdown":"https://insights.sbomify.com/CVE-2020-37287/index.md","name":"CVE-2020-37287","record":{"aliases":["GHSA-4v7v-gqf9-ww2g","GHSA-cqxq-3fq9-6g4p"],"analysis":null,"analysis_generated_by":null,"assigner":"VulnCheck","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-131","name":"Incorrect Calculation of Buffer Size"}],"description":"Vyper before 0.2.6 contains a call stack corruption vulnerability that causes incorrect function outputs when complex types with non-base members are passed as arguments. Contracts passing multi-dimensional arrays or structs to internal or external functions receive corrupted values because the compiler assumed each subtype size is 32.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Vyper before 0.2.6 Call Stack Corruption via Complex Type Function Arguments","id":"CVE-2020-37287","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Vyper 0.1.0b10 before 0.2.3 Invalid Jump Destination via Return in Nested Loops","id":"CVE-2020-37288"},"packages":[{"ecosystem":"PyPI","fixed":["0.2.6"],"introduced":["0"],"last_affected":[],"package":"vyper","purl":null,"source":"GHSA-4v7v-gqf9-ww2g"},{"ecosystem":"PyPI","fixed":["0.2.6"],"introduced":["0"],"last_affected":[],"package":"vyper","purl":"pkg:pypi/vyper","source":"GHSA-4v7v-gqf9-ww2g"}],"prev":{"headline":"Vyper 0.1.0b4 before 0.3.0 Memory Corruption via Nested Internal Function Calls","id":"CVE-2020-37286"},"products":["vyper"],"published":"2026-10-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-28","vendors":["vyperlang"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2020-37287/"}