{"answers":{"affected":"7 open source packages ship an affected version, including magento/community-edition, magento and magneto/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-3758 in the wild and no public exploit code.","fix":"Upgrade magento/community-edition to a fixed version for your release line: 2.2.11 or 2.3.4.","what":"CVE-2020-3758 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 29 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-3758 and fix it if it is affected.\n\nWhat it is: CVE-2020-3758 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 29 Jan 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-3758 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- magento/community-edition (Packagist): affected all versions; fixed in 2.2.11\n- magento/community-edition (Packagist): affected all versions; fixed in 2.2.11\n- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.4\n- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.4\n- magento (Bitnami): affected from 2.2.0; fixed in 2.2.11, 2.3.4\n- magneto/core (Packagist): affected all versions; fixed in 1.9.4.4\n- magneto/core (Packagist): affected all versions; fixed in 1.9.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-3758/ (Markdown: https://insights.sbomify.com/CVE-2020-3758/index.md)","id":"CVE-2020-3758","markdown":"https://insights.sbomify.com/CVE-2020-3758/index.md","name":"CVE-2020-3758","record":{"aliases":["BIT-magento-2020-3758","GHSA-p5q3-xg47-653m"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento e-commerce platform","requires_auth":"none","summary":"Attackers can inject malicious scripts into Magento pages, leading to sensitive information disclosure for users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"magento","vendor":"magento"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Magento versions 2.3.3 and earlier, 2.2.10 and earlier, 1.14.4.3 and earlier, and 1.9.4.3 and earlier have a stored cross-site scripting vulnerability. Successful exploitation could lead to sensitive information disclosure.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Magento stored cross-site scripting vulnerability","id":"CVE-2020-3758","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"magento:magento","products":["magento:magento"],"type":"xss","year":"2020"},"n_packages":7,"n_references":1,"next":{"headline":"Memory corruption in Adobe Digital Editions","id":"CVE-2020-3759"},"packages":[{"ecosystem":"Bitnami","fixed":["2.2.11","2.3.4"],"introduced":["2.2.0","2.3.0"],"last_affected":[],"package":"magento","purl":"pkg:bitnami/magento","source":"BIT-magento-2020-3758"},{"ecosystem":"Packagist","fixed":["2.2.11"],"introduced":["0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-p5q3-xg47-653m"},{"ecosystem":"Packagist","fixed":["2.2.11"],"introduced":["0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-p5q3-xg47-653m"},{"ecosystem":"Packagist","fixed":["2.3.4"],"introduced":["2.3.0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-p5q3-xg47-653m"},{"ecosystem":"Packagist","fixed":["2.3.4"],"introduced":["2.3.0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-p5q3-xg47-653m"},{"ecosystem":"Packagist","fixed":["1.9.4.4"],"introduced":["0"],"last_affected":[],"package":"magneto/core","purl":null,"source":"GHSA-p5q3-xg47-653m"},{"ecosystem":"Packagist","fixed":["1.9.4.4"],"introduced":["0"],"last_affected":[],"package":"magneto/core","purl":"pkg:composer/magneto/core","source":"GHSA-p5q3-xg47-653m"}],"prev":{"headline":"Memory corruption in Adobe Flash Player","id":"CVE-2020-3757"},"products":["Magento"],"published":"2020-01-29","related":[{"cvss_score":9.8,"headline":"Magento php object injection vulnerability","id":"CVE-2020-9664","kev_date_added":null,"published":"2020-07-22"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9576","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9578","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9579","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9580","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9582","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9583","kev_date_added":null,"published":"2020-06-26"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Adobe"]},"summary":"Attackers can inject malicious scripts into Magento pages, leading to sensitive information disclosure for users.","url":"https://insights.sbomify.com/CVE-2020-3758/"}