# CVE-2020-4037: Open Redirect in OAuth2 Proxy

> Attackers can exploit insufficient validation of redirect URLs in OAuth2 Proxy to send authenticated users to malicious sites.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-oauth2-proxy-2020-4037, GHSA-5m6c-jp6f-2vcv

## What is CVE-2020-4037?

CVE-2020-4037 is a medium-severity vulnerability in OAuth2 Proxy, published on 29 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In OAuth2 Proxy from version 5.1.1 and less than version 6.0.0, users can provide a redirect address for the proxy to send the authenticated user to at the end of the authentication flow. This is expected to be the original URL that the user was trying to access. This redirect URL is checked within the proxy and validated before redirecting the user to prevent malicious actors providing redirects to potentially harmful sites. This has been fixed in version 6.0.0.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2020-4037?

3 open source packages ship an affected version, including github.com/oauth2-proxy/oauth2-proxy and oauth2-proxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/oauth2-proxy/oauth2-proxy` | Go | From 5.1.1 | 6.0.0 |
| `github.com/oauth2-proxy/oauth2-proxy` | Go | From 5.1.1 | 6.0.0 |
| `oauth2-proxy` | Bitnami | From 5.1.1 | 6.0.0 |

Products: Oauth2 Proxy Project Oauth2 Proxy.

## How do I fix CVE-2020-4037?

Upgrade github.com/oauth2-proxy/oauth2-proxy to 6.0.0 or later.

## Is CVE-2020-4037 being exploited?

There is no known exploitation of CVE-2020-4037 in the wild and no public exploit code.

## Other vulnerabilities in OAuth2 Proxy

- [CVE-2026-40575](https://insights.sbomify.com/CVE-2026-40575/): OAuth2 Proxy has an Authentication Bypass via X-Forwarded-Uri Header Spoofing (critical 9.1)
- [CVE-2026-34457](https://insights.sbomify.com/CVE-2026-34457/): OAuth2 Proxy: Health Check User-Agent Matching Bypasses Authentication in auth_request Mode (critical 9.1)
- [CVE-2025-54576](https://insights.sbomify.com/CVE-2025-54576/): OAuth2-Proxy has authentication bypass in oauth2-proxy skip_auth_routes due to Query Parameter inclusion (critical 9.1)
- [CVE-2017-1000069](https://insights.sbomify.com/CVE-2017-1000069/): Cross-site Request Forgery (CSRF) (high 8.8)
- [CVE-2026-41059](https://insights.sbomify.com/CVE-2026-41059/): OAuth2 Proxy has an Authentication Bypass via Fragment Confusion in skip_auth_routes and skip_auth_regex (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-4037 and fix it if it is affected.

What it is: CVE-2020-4037 is a medium-severity vulnerability in OAuth2 Proxy, published on 29 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-4037 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/oauth2-proxy/oauth2-proxy (Go): affected from 5.1.1; fixed in 6.0.0
- github.com/oauth2-proxy/oauth2-proxy (Go): affected from 5.1.1; fixed in 6.0.0
- oauth2-proxy (Bitnami): affected from 5.1.1; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-4037/ (Markdown: https://insights.sbomify.com/CVE-2020-4037/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-4037
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-4037
- OSV: https://osv.dev/vulnerability/CVE-2020-4037

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-4037/
Summaries are generated and may contain mistakes; the official description above is the record.
