{"answers":{"affected":"4 open source packages ship an affected version, including maikuolan/phpmussel and phpmussel/phpmussel. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-4043 in the wild and no public exploit code.","fix":"Upgrade maikuolan/phpmussel to 1.6.0 or later.","what":"CVE-2020-4043 is a high-severity unsafe deserialization vulnerability in phpMussel, published on 10 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-4043 and fix it if it is affected.\n\nWhat it is: CVE-2020-4043 is a high-severity unsafe deserialization vulnerability in phpMussel, published on 10 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-4043 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- maikuolan/phpmussel (Packagist): affected from 1.0.0; fixed in 1.6.0\n- maikuolan/phpmussel (Packagist): affected from 1.0.0; fixed in 1.6.0\n- phpmussel/phpmussel (Packagist): affected from 1.0.0; fixed in 1.6.0\n- phpmussel/phpmussel (Packagist): affected from 1.0.0; fixed in 1.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-4043/ (Markdown: https://insights.sbomify.com/CVE-2020-4043/index.md)","id":"CVE-2020-4043","markdown":"https://insights.sbomify.com/CVE-2020-4043/index.md","name":"CVE-2020-4043","record":{"aliases":["GHSA-qr95-4mq5-r3fh"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP malware scanner","requires_auth":"low_privilege","summary":"Attackers can achieve arbitrary code execution by uploading a specially crafted file exploiting a Phar unserialization vulnerability in phpMussel.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"phpmussel","vendor":"phpmussel_project"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"phpMussel from versions 1.0.0 and less than 1.6.0 has an unserialization vulnerability in PHP's phar wrapper. Uploading a specially crafted file to an affected version allows arbitrary code execution (discovered, tested, and confirmed by myself), so the risk factor should be regarded as very high. Newer phpMussel versions don't use PHP's phar wrapper, and are therefore unaffected. This has been fixed in version 1.6.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Phar unserialization vulnerability in phpMussel","id":"CVE-2020-4043","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2020"},"n_packages":4,"n_references":5,"next":{"headline":"Local users can perform a buffer overflow attack against the xrdp-sesman service and then impersonate it","id":"CVE-2020-4044"},"packages":[{"ecosystem":"Packagist","fixed":["1.6.0"],"introduced":["1.0.0"],"last_affected":[],"package":"maikuolan/phpmussel","purl":null,"source":"GHSA-qr95-4mq5-r3fh"},{"ecosystem":"Packagist","fixed":["1.6.0"],"introduced":["1.0.0"],"last_affected":[],"package":"maikuolan/phpmussel","purl":"pkg:composer/maikuolan/phpmussel","source":"GHSA-qr95-4mq5-r3fh"},{"ecosystem":"Packagist","fixed":["1.6.0"],"introduced":["1.0.0"],"last_affected":[],"package":"phpmussel/phpmussel","purl":null,"source":"GHSA-qr95-4mq5-r3fh"},{"ecosystem":"Packagist","fixed":["1.6.0"],"introduced":["1.0.0"],"last_affected":[],"package":"phpmussel/phpmussel","purl":"pkg:composer/phpmussel/phpmussel","source":"GHSA-qr95-4mq5-r3fh"}],"prev":{"headline":"Authentication bypass in Bareos","id":"CVE-2020-4042"},"products":["phpMussel"],"published":"2020-06-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["phpMussel"]},"summary":"Attackers can achieve arbitrary code execution by uploading a specially crafted file exploiting a Phar unserialization vulnerability in phpMussel.","url":"https://insights.sbomify.com/CVE-2020-4043/"}