# CVE-2020-4043: Phar unserialization vulnerability in phpMussel

> Attackers can achieve arbitrary code execution by uploading a specially crafted file exploiting a Phar unserialization vulnerability in phpMussel.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qr95-4mq5-r3fh

## What is CVE-2020-4043?

CVE-2020-4043 is a high-severity unsafe deserialization vulnerability in phpMussel, published on 10 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

phpMussel from versions 1.0.0 and less than 1.6.0 has an unserialization vulnerability in PHP's phar wrapper. Uploading a specially crafted file to an affected version allows arbitrary code execution (discovered, tested, and confirmed by myself), so the risk factor should be regarded as very high. Newer phpMussel versions don't use PHP's phar wrapper, and are therefore unaffected. This has been fixed in version 1.6.0.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-4043?

4 open source packages ship an affected version, including maikuolan/phpmussel and phpmussel/phpmussel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `maikuolan/phpmussel` | Packagist | From 1.0.0 | 1.6.0 |
| `maikuolan/phpmussel` | Packagist | From 1.0.0 | 1.6.0 |
| `phpmussel/phpmussel` | Packagist | From 1.0.0 | 1.6.0 |
| `phpmussel/phpmussel` | Packagist | From 1.0.0 | 1.6.0 |

Products: Phpmussel Project Phpmussel.

## How do I fix CVE-2020-4043?

Upgrade maikuolan/phpmussel to 1.6.0 or later.

## Is CVE-2020-4043 being exploited?

There is no known exploitation of CVE-2020-4043 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-4043 and fix it if it is affected.

What it is: CVE-2020-4043 is a high-severity unsafe deserialization vulnerability in phpMussel, published on 10 Jun 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-4043 in the wild and no public exploit code.

Affected packages and fixed versions:
- maikuolan/phpmussel (Packagist): affected from 1.0.0; fixed in 1.6.0
- maikuolan/phpmussel (Packagist): affected from 1.0.0; fixed in 1.6.0
- phpmussel/phpmussel (Packagist): affected from 1.0.0; fixed in 1.6.0
- phpmussel/phpmussel (Packagist): affected from 1.0.0; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-4043/ (Markdown: https://insights.sbomify.com/CVE-2020-4043/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-4043
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-4043
- OSV: https://osv.dev/vulnerability/CVE-2020-4043

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-4043/
Summaries are generated and may contain mistakes; the official description above is the record.
