{"answers":{"affected":"2 open source packages ship an affected version, including ssb-db. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-4045 in the wild and no public exploit code.","fix":"Upgrade ssb-db to 20.0.1 or later.","what":"CVE-2020-4045 is a high-severity vulnerability in ssbc SSB-DB, published on 11 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-4045 and fix it if it is affected.\n\nWhat it is: CVE-2020-4045 is a high-severity vulnerability in ssbc SSB-DB, published on 11 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-4045 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ssb-db (npm): affected from 20.0.0; fixed in 20.0.1\n- ssb-db (npm): affected from 20.0.0; fixed in 20.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-4045/ (Markdown: https://insights.sbomify.com/CVE-2020-4045/index.md)","id":"CVE-2020-4045","markdown":"https://insights.sbomify.com/CVE-2020-4045/index.md","name":"CVE-2020-4045","record":{"aliases":["GHSA-mpgr-2cx9-327h"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"SSB-DB library","requires_auth":"none","summary":"A bug in SSB-DB allows malicious peers to access decrypted private messages when used with SSB-Server, requiring an upgrade to fix.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ssb-db","vendor":"scuttlebutt"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"SSB-DB version 20.0.0 has an information disclosure vulnerability. The get() method is supposed to only decrypt messages when you explicitly ask it to, but there is a bug where it's decrypting any message that it can. This means that it is returning the decrypted content of private messages, which a malicious peer could use to get access to private data. This only affects peers running SSB-DB@20.0.0 who also have private messages, and is only known to be exploitable if you're also running SSB-OOO (default in SSB-Server), which exposes a thin wrapper around get() to anonymous peers. This is fixed in version 20.0.1. Note that users of SSB-Server verion 16.0.0 should upgrade to 16.0.1 to get the fixed version of SSB-DB.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in SSB-DB","id":"CVE-2020-4045","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Authenticated XSS through embed block in WordPress","id":"CVE-2020-4046"},"packages":[{"ecosystem":"npm","fixed":["20.0.1"],"introduced":["20.0.0"],"last_affected":[],"package":"ssb-db","purl":null,"source":"GHSA-mpgr-2cx9-327h"},{"ecosystem":"npm","fixed":["20.0.1"],"introduced":["20.0.0"],"last_affected":[],"package":"ssb-db","purl":"pkg:npm/ssb-db","source":"GHSA-mpgr-2cx9-327h"}],"prev":{"headline":"Local users can perform a buffer overflow attack against the xrdp-sesman service and then impersonate it","id":"CVE-2020-4044"},"products":["SSB-DB"],"published":"2020-06-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["ssbc"]},"summary":"A bug in SSB-DB allows malicious peers to access decrypted private messages when used with SSB-Server, requiring an upgrade to fix.","url":"https://insights.sbomify.com/CVE-2020-4045/"}