# CVE-2020-4051: XSS in Dijit Editor's LinkDialog plugin

> Cross-site scripting in Dijit Editor's LinkDialog plugin allows attackers to execute arbitrary scripts in user browsers.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-4051, GHSA-cxjc-r2fp-7mq6, UBUNTU-CVE-2020-4051

## What is CVE-2020-4051?

CVE-2020-4051 is a low-severity cross-site scripting vulnerability in Debian Debian Linux, published on 15 Jun 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Dijit before versions 1.11.11, and greater than or equal to 1.12.0 and less than 1.12.9, and greater than or equal to 1.13.0 and less than 1.13.8, and greater than or equal to 1.14.0 and less than 1.14.7, and greater than or equal to 1.15.0 and less than 1.15.4, and greater than or equal to 1.16.0 and less than 1.16.3, there is a cross-site scripting vulnerability in the Editor's LinkDialog plugin. This has been fixed in 1.11.11, 1.12.9, 1.13.8, 1.14.7, 1.15.4, 1.16.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-4051?

12 open source packages ship an affected version, including dijit. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dijit` | npm | All versions | 1.11.11 |
| `dijit` | npm | All versions | 1.11.11 |
| `dijit` | npm | From 1.12.0 | 1.12.9 |
| `dijit` | npm | From 1.12.0 | 1.12.9 |
| `dijit` | npm | From 1.13.0 | 1.13.8 |
| `dijit` | npm | From 1.13.0 | 1.13.8 |
| `dijit` | npm | From 1.14.0 | 1.14.7 |
| `dijit` | npm | From 1.14.0 | 1.14.7 |
| `dijit` | npm | From 1.15.0 | 1.15.4 |
| `dijit` | npm | From 1.15.0 | 1.15.4 |
| `dijit` | npm | From 1.16.0 | 1.16.3 |
| `dijit` | npm | From 1.16.0 | 1.16.3 |

Products: Debian Debian Linux, Netapp Active Iq Unified Manager, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Openjsf Dijit.

## How do I fix CVE-2020-4051?

Upgrade dijit to a fixed version for your release line: 1.11.11, 1.12.9, 1.13.8 or 1.14.7.

## Is CVE-2020-4051 being exploited?

There is no known exploitation of CVE-2020-4051 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-4051 and fix it if it is affected.

What it is: CVE-2020-4051 is a low-severity cross-site scripting vulnerability in Debian Debian Linux, published on 15 Jun 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-4051 in the wild and no public exploit code.

Affected packages and fixed versions:
- dijit (npm): affected all versions; fixed in 1.11.11
- dijit (npm): affected all versions; fixed in 1.11.11
- dijit (npm): affected from 1.12.0; fixed in 1.12.9
- dijit (npm): affected from 1.12.0; fixed in 1.12.9
- dijit (npm): affected from 1.13.0; fixed in 1.13.8
- dijit (npm): affected from 1.13.0; fixed in 1.13.8
- dijit (npm): affected from 1.14.0; fixed in 1.14.7
- dijit (npm): affected from 1.14.0; fixed in 1.14.7
- dijit (npm): affected from 1.15.0; fixed in 1.15.4
- dijit (npm): affected from 1.15.0; fixed in 1.15.4
- dijit (npm): affected from 1.16.0; fixed in 1.16.3
- dijit (npm): affected from 1.16.0; fixed in 1.16.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-4051/ (Markdown: https://insights.sbomify.com/CVE-2020-4051/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-4051
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-4051
- OSV: https://osv.dev/vulnerability/CVE-2020-4051

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-4051/
Summaries are generated and may contain mistakes; the official description above is the record.
