{"answers":{"affected":"2 open source packages ship an affected version, including sanitize. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-4054 in the wild and no public exploit code.","fix":"Upgrade sanitize to 5.2.1 or later.","what":"CVE-2020-4054 is a high-severity vulnerability in rgrove Sanitize, published on 16 Jun 2020."},"fix_prompt":"Check this codebase for CVE-2020-4054 and fix it if it is affected.\n\nWhat it is: CVE-2020-4054 is a high-severity vulnerability in rgrove Sanitize, published on 16 Jun 2020. \nExploitation: There is no known exploitation of CVE-2020-4054 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sanitize (RubyGems): affected from 3.0.0; fixed in 5.2.1\n- sanitize (RubyGems): affected from 3.0.0; fixed in 5.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-4054/ (Markdown: https://insights.sbomify.com/CVE-2020-4054/index.md)","id":"CVE-2020-4054","markdown":"https://insights.sbomify.com/CVE-2020-4054/index.md","name":"CVE-2020-4054","record":{"aliases":["DEBIAN-CVE-2020-4054","DSA-4730-1","GHSA-p4x4-rw2p-8j8m","UBUNTU-CVE-2020-4054","USN-4543-1"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"sanitize","vendor":"sanitize_project"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Sanitize (RubyGem sanitize) greater than or equal to 3.0.0 and less than 5.2.1, there is a cross-site scripting vulnerability. When HTML is sanitized using Sanitize's \"relaxed\" config, or a custom config that allows certain elements, some content in a math or svg element may not be sanitized correctly even if math and svg are not in the allowlist. You are likely to be vulnerable to this issue if you use Sanitize's relaxed config or a custom config that allows one or more of the following HTML elements: iframe, math, noembed, noframes, noscript, plaintext, script, style, svg, xmp. Using carefully crafted input, an attacker may be able to sneak arbitrary HTML through Sanitize, potentially resulting in XSS (cross-site scripting) or other undesired behavior when that HTML is rendered in a browser. This has been fixed in 5.2.1.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in Sanitize","id":"CVE-2020-4054","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":null,"year":"2020"},"n_packages":2,"n_references":5,"next":{"headline":"Command Injection in mversion","id":"CVE-2020-4059"},"packages":[{"ecosystem":"RubyGems","fixed":["5.2.1"],"introduced":["3.0.0"],"last_affected":[],"package":"sanitize","purl":null,"source":"GHSA-p4x4-rw2p-8j8m"},{"ecosystem":"RubyGems","fixed":["5.2.1"],"introduced":["3.0.0"],"last_affected":[],"package":"sanitize","purl":"pkg:gem/sanitize","source":"GHSA-p4x4-rw2p-8j8m"}],"prev":{"headline":"Path Traversal in Helm Plugin Archive","id":"CVE-2020-4053"},"products":["Sanitize"],"published":"2020-06-16","related":[{"cvss_score":7.5,"headline":"Sanitize vulnerable to Improper Input Validation and Cross-site Scripting","id":"CVE-2018-3740","kev_date_added":null,"published":"2018-03-30"},{"cvss_score":6.1,"headline":"Sanitize vulnerable to Cross-site Scripting via Improper neutralization of `noscript` element","id":"CVE-2023-23627","kev_date_added":null,"published":"2023-01-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["rgrove"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2020-4054/"}