# CVE-2020-4054: Cross-site Scripting in Sanitize


- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 16 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-4054, DSA-4730-1, GHSA-p4x4-rw2p-8j8m, UBUNTU-CVE-2020-4054, USN-4543-1

## What is CVE-2020-4054?

CVE-2020-4054 is a high-severity vulnerability in rgrove Sanitize, published on 16 Jun 2020. 

### Official description

In Sanitize (RubyGem sanitize) greater than or equal to 3.0.0 and less than 5.2.1, there is a cross-site scripting vulnerability. When HTML is sanitized using Sanitize's "relaxed" config, or a custom config that allows certain elements, some content in a math or svg element may not be sanitized correctly even if math and svg are not in the allowlist. You are likely to be vulnerable to this issue if you use Sanitize's relaxed config or a custom config that allows one or more of the following HTML elements: iframe, math, noembed, noframes, noscript, plaintext, script, style, svg, xmp. Using carefully crafted input, an attacker may be able to sneak arbitrary HTML through Sanitize, potentially resulting in XSS (cross-site scripting) or other undesired behavior when that HTML is rendered in a browser. This has been fixed in 5.2.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-4054?

2 open source packages ship an affected version, including sanitize. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sanitize` | RubyGems | From 3.0.0 | 5.2.1 |
| `sanitize` | RubyGems | From 3.0.0 | 5.2.1 |

Products: Sanitize Project Sanitize.

## How do I fix CVE-2020-4054?

Upgrade sanitize to 5.2.1 or later.

## Is CVE-2020-4054 being exploited?

There is no known exploitation of CVE-2020-4054 in the wild and no public exploit code.

## Other vulnerabilities in rgrove Sanitize

- [CVE-2018-3740](https://insights.sbomify.com/CVE-2018-3740/): Sanitize vulnerable to Improper Input Validation and Cross-site Scripting (high 7.5)
- [CVE-2023-23627](https://insights.sbomify.com/CVE-2023-23627/): Sanitize vulnerable to Cross-site Scripting via Improper neutralization of `noscript` element (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-4054 and fix it if it is affected.

What it is: CVE-2020-4054 is a high-severity vulnerability in rgrove Sanitize, published on 16 Jun 2020. 
Exploitation: There is no known exploitation of CVE-2020-4054 in the wild and no public exploit code.

Affected packages and fixed versions:
- sanitize (RubyGems): affected from 3.0.0; fixed in 5.2.1
- sanitize (RubyGems): affected from 3.0.0; fixed in 5.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-4054/ (Markdown: https://insights.sbomify.com/CVE-2020-4054/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-4054
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-4054
- OSV: https://osv.dev/vulnerability/CVE-2020-4054

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-4054/
Summaries are generated and may contain mistakes; the official description above is the record.
