# CVE-2020-4059: Command Injection in mversion


- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 18 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qjg4-w4c6-f6c6

## What is CVE-2020-4059?

CVE-2020-4059 is a high-severity vulnerability in mikaelbr mversion, published on 18 Jun 2020. 

### Official description

In mversion before 2.0.0, there is a command injection vulnerability. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. This vulnerability is patched by version 2.0.0. Previous releases are deprecated in npm. As a workaround, make sure to escape git commit messages when using the commitMessage option for the update function.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2020-4059?

2 open source packages ship an affected version, including mversion. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mversion` | npm | All versions | 2.0.0 |
| `mversion` | npm | All versions | 2.0.0 |

Products: Mversion Project Mversion.

## How do I fix CVE-2020-4059?

Upgrade mversion to 2.0.0 or later.

## Is CVE-2020-4059 being exploited?

There is no known exploitation of CVE-2020-4059 in the wild and no public exploit code.

## Other vulnerabilities in mikaelbr mversion

- [CVE-2020-7688](https://insights.sbomify.com/CVE-2020-7688/): Command Injection (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-4059 and fix it if it is affected.

What it is: CVE-2020-4059 is a high-severity vulnerability in mikaelbr mversion, published on 18 Jun 2020. 
Exploitation: There is no known exploitation of CVE-2020-4059 in the wild and no public exploit code.

Affected packages and fixed versions:
- mversion (npm): affected all versions; fixed in 2.0.0
- mversion (npm): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-4059/ (Markdown: https://insights.sbomify.com/CVE-2020-4059/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-4059
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-4059
- OSV: https://osv.dev/vulnerability/CVE-2020-4059

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-4059/
Summaries are generated and may contain mistakes; the official description above is the record.
