CVE-2020-4066 Command Injection in Limdu trainBatch function

Low 3.8 Published Updated

An attacker can execute arbitrary commands via the trainBatch function in the Limdu library, affecting developers who use this function without sanitizing inputs.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-4066?

CVE-2020-4066 is a low-severity command injection vulnerability in erelsgl Limdu, published on 22 Jun 2020. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

In Limdu before 0.95, the trainBatch function has a command injection vulnerability. Clients of the Limdu library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability. This has been patched in 0.95.

Weakness: CWE-78

Which versions are affected by CVE-2020-4066?

2 open source packages ship an affected version, including limdu. It affects 1 product.

PackageAffectedFixed in
limdu npmAll versions0.9.5
limdu npmAll versions0.9.5

Products include Limdu Project Limdu.

How do I fix CVE-2020-4066?

Upgrade limdu to 0.9.5 or later.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2020-4066 being exploited?

There is no known exploitation of CVE-2020-4066 in the wild and no public exploit code.

Sources

Also known as GHSA-77qv-gh6f-pgh4.

Is CVE-2020-4066 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free