# CVE-2020-4066: Command Injection in Limdu trainBatch function

> An attacker can execute arbitrary commands via the trainBatch function in the Limdu library, affecting developers who use this function without sanitizing inputs.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-77qv-gh6f-pgh4

## What is CVE-2020-4066?

CVE-2020-4066 is a low-severity command injection vulnerability in erelsgl Limdu, published on 22 Jun 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In Limdu before 0.95, the trainBatch function has a command injection vulnerability. Clients of the Limdu library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability. This has been patched in 0.95.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-4066?

2 open source packages ship an affected version, including limdu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `limdu` | npm | All versions | 0.9.5 |
| `limdu` | npm | All versions | 0.9.5 |

Products: Limdu Project Limdu.

## How do I fix CVE-2020-4066?

Upgrade limdu to 0.9.5 or later.

## Is CVE-2020-4066 being exploited?

There is no known exploitation of CVE-2020-4066 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-4066 and fix it if it is affected.

What it is: CVE-2020-4066 is a low-severity command injection vulnerability in erelsgl Limdu, published on 22 Jun 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-4066 in the wild and no public exploit code.

Affected packages and fixed versions:
- limdu (npm): affected all versions; fixed in 0.9.5
- limdu (npm): affected all versions; fixed in 0.9.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-4066/ (Markdown: https://insights.sbomify.com/CVE-2020-4066/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-4066
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-4066
- OSV: https://osv.dev/vulnerability/CVE-2020-4066

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-4066/
Summaries are generated and may contain mistakes; the official description above is the record.
