CVE-2020-4074 Improper Authentication

High 8.9 Published Updated

Attackers can forge requests to bypass authentication and execute admin commands in PrestaShop, requiring an upgrade to the latest version.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2020-4074?

CVE-2020-4074 is a high-severity authentication bypass vulnerability in Prestashop Prestashop, published on 2 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In PrestaShop from version 1.5.0.0 and before version 1.7.6.6, the authentication system is malformed and an attacker is able to forge requests and execute admin commands. The problem is fixed in 1.7.6.6.

Weakness: CWE-287

Which versions are affected by CVE-2020-4074?

It affects 1 product.

Products include Prestashop Prestashop.

How do I fix CVE-2020-4074?

No fix has been published for CVE-2020-4074 yet. Limit exposure of the affected software until one is available.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2020-4074 being exploited?

There is no known exploitation of CVE-2020-4074 in the wild and no public exploit code.

All Prestashop Prestashop vulnerabilities

Sources

Also known as GHSA-ccvh-jh5x-mpg4.

Is CVE-2020-4074 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free