# CVE-2020-5187: DNN Path Traversal via Zip Slip

> Attackers can exploit a path traversal vulnerability in DNN to read or modify arbitrary files on the server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-4qf5-7xc2-wqpg

## What is CVE-2020-5187?

CVE-2020-5187 is a high-severity path traversal vulnerability in Dnnsoftware Dotnetnuke, published on 24 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

DNN (formerly DotNetNuke) through 9.4.4 allows Path Traversal (issue 2 of 2).

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-5187?

2 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `DotNetNuke.Core` | NuGet | All versions | 9.5.0 |
| `DotNetNuke.Core` | NuGet | All versions | 9.5.0 |

Products: Dnnsoftware Dotnetnuke.

## How do I fix CVE-2020-5187?

Upgrade DotNetNuke.Core to 9.5.0 or later.

## Is CVE-2020-5187 being exploited?

There is no known exploitation of CVE-2020-5187 in the wild and no public exploit code.

## Other vulnerabilities in Dnnsoftware Dotnetnuke

- [CVE-2017-9822](https://insights.sbomify.com/CVE-2017-9822/): DotNetNuke (DNN) Remote Code Execution (high 8.8, exploited in the wild)
- [CVE-2018-15811](https://insights.sbomify.com/CVE-2018-15811/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2018-18325](https://insights.sbomify.com/CVE-2018-18325/): DotNetNuke (DNN) Inadequate Encryption Strength (high 7.5, exploited in the wild)
- [CVE-2025-64095](https://insights.sbomify.com/CVE-2025-64095/): DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite (critical 10.0)
- [CVE-2006-3601](https://insights.sbomify.com/CVE-2006-3601/): Privilege escalation in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5187 and fix it if it is affected.

What it is: CVE-2020-5187 is a high-severity path traversal vulnerability in Dnnsoftware Dotnetnuke, published on 24 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-5187 in the wild and no public exploit code.

Affected packages and fixed versions:
- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.5.0
- DotNetNuke.Core (NuGet): affected all versions; fixed in 9.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5187/ (Markdown: https://insights.sbomify.com/CVE-2020-5187/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5187
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5187
- OSV: https://osv.dev/vulnerability/CVE-2020-5187

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5187/
Summaries are generated and may contain mistakes; the official description above is the record.
