# CVE-2020-5206: Authentication Bypass For Endpoints With Anonymous Access in OpenCast

> Attackers can bypass authentication using fake remember-me cookies to access non-public content and assume administrator privileges in Opencast.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vmm6-w4cf-7f3x

## What is CVE-2020-5206?

CVE-2020-5206 is a high-severity authentication bypass vulnerability in opencast, published on 30 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Opencast before 7.6 and 8.1, using a remember-me cookie with an arbitrary username can cause Opencast to assume proper authentication for that user even if the remember-me cookie was incorrect given that the attacked endpoint also allows anonymous access. This way, an attacker can, for example, fake a remember-me token, assume the identity of the global system administrator and request non-public content from the search service without ever providing any proper authentication. This problem is fixed in Opencast 7.6 and Opencast 8.1

Weakness: CWE-287 (Improper Authentication), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2020-5206?

4 open source packages ship an affected version, including org.opencastproject:opencast-kernel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencastproject:opencast-kernel` | Maven | All versions | 7.6 |
| `org.opencastproject:opencast-kernel` | Maven | All versions | 7.6 |
| `org.opencastproject:opencast-kernel` | Maven | From 8.0 | 8.1 |
| `org.opencastproject:opencast-kernel` | Maven | From 8.0 | 8.1 |

Products: Apereo Opencast.

## How do I fix CVE-2020-5206?

Upgrade org.opencastproject:opencast-kernel to a fixed version for your release line: 7.6 or 8.1.

## Is CVE-2020-5206 being exploited?

There is no known exploitation of CVE-2020-5206 in the wild and no public exploit code.

## Other vulnerabilities in opencast

- [CVE-2021-43821](https://insights.sbomify.com/CVE-2021-43821/): Files Accessible to External Parties in Opencast (critical 9.9)
- [CVE-2021-32623](https://insights.sbomify.com/CVE-2021-32623/): Opencast vulnerable to billion laughs attack (XML bomb) (high 8.1)
- [CVE-2020-5229](https://insights.sbomify.com/CVE-2020-5229/): Opencast stores passwords using outdated MD5 hash algorithm (high 7.7)
- [CVE-2020-5230](https://insights.sbomify.com/CVE-2020-5230/): Opencast uses unsafe identifiers (high 7.7)
- [CVE-2020-5228](https://insights.sbomify.com/CVE-2020-5228/): Opencast allows unauthorized public access via OAI-PMH (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5206 and fix it if it is affected.

What it is: CVE-2020-5206 is a high-severity authentication bypass vulnerability in opencast, published on 30 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5206 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencastproject:opencast-kernel (Maven): affected all versions; fixed in 7.6
- org.opencastproject:opencast-kernel (Maven): affected all versions; fixed in 7.6
- org.opencastproject:opencast-kernel (Maven): affected from 8.0; fixed in 8.1
- org.opencastproject:opencast-kernel (Maven): affected from 8.0; fixed in 8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5206/ (Markdown: https://insights.sbomify.com/CVE-2020-5206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5206
- OSV: https://osv.dev/vulnerability/CVE-2020-5206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5206/
Summaries are generated and may contain mistakes; the official description above is the record.
