CVE-2020-5215 Segmentation faultin TensorFlow when converting a Python string to tf.float16
An attacker can cause a segmentation fault and denial of service in TensorFlow by providing a string where a float16 value is expected during eager execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-5215?
CVE-2020-5215 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 28 Jan 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
In TensorFlow before 1.15.2 and 2.0.1, converting a string (from Python) to a tf.float16 value results in a segmentation fault in eager mode as the format checks for this use case are only in the graph mode. This issue can lead to denial of service in inference/training where a malicious attacker can send a data point which contains a string instead of a tf.float16 value. Similar effects can be obtained by manipulating saved models and checkpoints whereby replacing a scalar tf.float16 value with a scalar string will trigger this issue due to automatic conversions. This can be easily reproduced by tf.constant("hello", tf.float16), if eager execution is enabled. This issue is patched in TensorFlow 1.15.1 and 2.0.1 with this vulnerability patched. TensorFlow 2.1.0 was released after we fixed the issue, thus it is not affected. Users are encouraged to switch to TensorFlow 1.15.1, 2.0.1 or 2.1.0.
Which versions are affected by CVE-2020-5215?
16 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tensorflow Bitnami | All versions | 1.15.2, 2.0.1 |
tensorflow PyPI | All versions | 1.15.2, 2.0.1 |
tensorflow PyPI | All versions | 1.15.2 |
tensorflow PyPI | All versions | 1.15.2 |
tensorflow PyPI | From 2.0.0 | 2.0.1 |
tensorflow PyPI | From 2.0.0 | 2.0.1 |
10 more packages
tensorflow-cpu PyPI | All versions | 1.15.2, 2.0.1 |
tensorflow-cpu PyPI | All versions | 1.15.2 |
tensorflow-cpu PyPI | All versions | 1.15.2 |
tensorflow-cpu PyPI | From 2.0.0 | 2.0.1 |
tensorflow-cpu PyPI | From 2.0.0 | 2.0.1 |
tensorflow-gpu PyPI | All versions | 1.15.2, 2.0.1 |
tensorflow-gpu PyPI | All versions | 1.15.2 |
tensorflow-gpu PyPI | All versions | 1.15.2 |
tensorflow-gpu PyPI | From 2.0.0 | 2.0.1 |
tensorflow-gpu PyPI | From 2.0.0 | 2.0.1 |
Products include Google Tensorflow.
How do I fix CVE-2020-5215?
Upgrade tensorflow to a fixed version for your release line: 1.15.2 or 2.0.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-5215 being exploited?
There is no known exploitation of CVE-2020-5215 in the wild and no public exploit code.
Other vulnerabilities in Google Tensorflow
- CVE-2023-25668 TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation
- CVE-2018-7575 Integer Overflow or Wraparound in Google TensorFlow
- CVE-2021-37678 Arbitrary code execution due to YAML deserialization
- CVE-2021-35958 Path traversal in n/a
- CVE-2020-15202 Integer truncation in Shard API usage
Sources
Also known as BIT-tensorflow-2020-5215, GHSA-977j-xj7q-2jr9, PYSEC-2020-258, PYSEC-2020-303, PYSEC-2020-338.