# CVE-2020-5215: Segmentation faultin TensorFlow when converting a Python string to tf.float16

> An attacker can cause a segmentation fault and denial of service in TensorFlow by providing a string where a float16 value is expected during eager execution.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-tensorflow-2020-5215, GHSA-977j-xj7q-2jr9, PYSEC-2020-258, PYSEC-2020-303, PYSEC-2020-338

## What is CVE-2020-5215?

CVE-2020-5215 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 28 Jan 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In TensorFlow before 1.15.2 and 2.0.1, converting a string (from Python) to a tf.float16 value results in a segmentation fault in eager mode as the format checks for this use case are only in the graph mode. This issue can lead to denial of service in inference/training where a malicious attacker can send a data point which contains a string instead of a tf.float16 value. Similar effects can be obtained by manipulating saved models and checkpoints whereby replacing a scalar tf.float16 value with a scalar string will trigger this issue due to automatic conversions. This can be easily reproduced by tf.constant("hello", tf.float16), if eager execution is enabled. This issue is patched in TensorFlow 1.15.1 and 2.0.1 with this vulnerability patched. TensorFlow 2.1.0 was released after we fixed the issue, thus it is not affected. Users are encouraged to switch to TensorFlow 1.15.1, 2.0.1 or 2.1.0.

Weakness: CWE-20 (Improper Input Validation), CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2020-5215?

16 open source packages ship an affected version, including tensorflow, tensorflow-cpu and tensorflow-gpu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tensorflow` | Bitnami | All versions | 1.15.2, 2.0.1 |
| `tensorflow` | PyPI | All versions | 1.15.2, 2.0.1 |
| `tensorflow` | PyPI | All versions | 1.15.2 |
| `tensorflow` | PyPI | All versions | 1.15.2 |
| `tensorflow` | PyPI | From 2.0.0 | 2.0.1 |
| `tensorflow` | PyPI | From 2.0.0 | 2.0.1 |
| `tensorflow-cpu` | PyPI | All versions | 1.15.2, 2.0.1 |
| `tensorflow-cpu` | PyPI | All versions | 1.15.2 |
| `tensorflow-cpu` | PyPI | All versions | 1.15.2 |
| `tensorflow-cpu` | PyPI | From 2.0.0 | 2.0.1 |
| `tensorflow-cpu` | PyPI | From 2.0.0 | 2.0.1 |
| `tensorflow-gpu` | PyPI | All versions | 1.15.2, 2.0.1 |
| `tensorflow-gpu` | PyPI | All versions | 1.15.2 |
| `tensorflow-gpu` | PyPI | All versions | 1.15.2 |
| `tensorflow-gpu` | PyPI | From 2.0.0 | 2.0.1 |
| `tensorflow-gpu` | PyPI | From 2.0.0 | 2.0.1 |

Products: Google Tensorflow.

## How do I fix CVE-2020-5215?

Upgrade tensorflow to a fixed version for your release line: 1.15.2 or 2.0.1.

## Is CVE-2020-5215 being exploited?

There is no known exploitation of CVE-2020-5215 in the wild and no public exploit code.

## Other vulnerabilities in Google Tensorflow

- [CVE-2023-25668](https://insights.sbomify.com/CVE-2023-25668/): TensorFlow vulnerable to heap out-of-buffer read in the QuantizeAndDequantize operation (critical 9.8)
- [CVE-2018-7575](https://insights.sbomify.com/CVE-2018-7575/): Integer Overflow or Wraparound in Google TensorFlow (critical 9.8)
- [CVE-2021-37678](https://insights.sbomify.com/CVE-2021-37678/): Arbitrary code execution due to YAML deserialization (critical 9.3)
- [CVE-2021-35958](https://insights.sbomify.com/CVE-2021-35958/): Path traversal in n/a (critical 9.1)
- [CVE-2020-15202](https://insights.sbomify.com/CVE-2020-15202/): Integer truncation in Shard API usage (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5215 and fix it if it is affected.

What it is: CVE-2020-5215 is a medium-severity denial of service vulnerability in Google Tensorflow, published on 28 Jan 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5215 in the wild and no public exploit code.

Affected packages and fixed versions:
- tensorflow (Bitnami): affected all versions; fixed in 1.15.2, 2.0.1
- tensorflow (PyPI): affected all versions; fixed in 1.15.2, 2.0.1
- tensorflow (PyPI): affected all versions; fixed in 1.15.2
- tensorflow (PyPI): affected all versions; fixed in 1.15.2
- tensorflow (PyPI): affected from 2.0.0; fixed in 2.0.1
- tensorflow (PyPI): affected from 2.0.0; fixed in 2.0.1
- tensorflow-cpu (PyPI): affected all versions; fixed in 1.15.2, 2.0.1
- tensorflow-cpu (PyPI): affected all versions; fixed in 1.15.2
- tensorflow-cpu (PyPI): affected all versions; fixed in 1.15.2
- tensorflow-cpu (PyPI): affected from 2.0.0; fixed in 2.0.1
- tensorflow-cpu (PyPI): affected from 2.0.0; fixed in 2.0.1
- tensorflow-gpu (PyPI): affected all versions; fixed in 1.15.2, 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5215/ (Markdown: https://insights.sbomify.com/CVE-2020-5215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5215
- OSV: https://osv.dev/vulnerability/CVE-2020-5215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5215/
Summaries are generated and may contain mistakes; the official description above is the record.
