# CVE-2020-5216: Limited header injection when using dynamic overrides with user input in RubyGems secure_headers

> Attackers can inject newlines into Content-Security-Policy headers via user input, bypassing security restrictions in Ruby applications using the secure_headers gem.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-5216, GHSA-w978-rmpf-qmwg, UBUNTU-CVE-2020-5216

## What is CVE-2020-5216?

CVE-2020-5216 is a medium-severity vulnerability in Twitter secure_headers, published on 23 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.9.0, 5.2.0, and 6.3.0. If user-supplied input was passed into append/override_content_security_policy_directives, a newline could be injected leading to limited header injection. Upon seeing a newline in the header, rails will silently create a new Content-Security-Policy header with the remaining value of the original string. It will continue to create new headers for each newline. This has been fixed in 6.3.0, 5.2.0, and 3.9.0.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2020-5216?

6 open source packages ship an affected version, including secure_headers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `secure_headers` | RubyGems | All versions | 3.9.0 |
| `secure_headers` | RubyGems | All versions | 3.9.0 |
| `secure_headers` | RubyGems | From 5.0.0 | 5.2.0 |
| `secure_headers` | RubyGems | From 5.0.0 | 5.2.0 |
| `secure_headers` | RubyGems | From 6.0.0 | 6.3.0 |
| `secure_headers` | RubyGems | From 6.0.0 | 6.3.0 |

Products: Twitter Secure Headers.

## How do I fix CVE-2020-5216?

Upgrade secure_headers to a fixed version for your release line: 3.9.0, 5.2.0 or 6.3.0.

## Is CVE-2020-5216 being exploited?

There is no known exploitation of CVE-2020-5216 in the wild and no public exploit code.

## Other vulnerabilities in Twitter secure_headers

- [CVE-2020-5217](https://insights.sbomify.com/CVE-2020-5217/): Directive injection when using dynamic overrides with user input in RubyGems secure_headers (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5216 and fix it if it is affected.

What it is: CVE-2020-5216 is a medium-severity vulnerability in Twitter secure_headers, published on 23 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5216 in the wild and no public exploit code.

Affected packages and fixed versions:
- secure_headers (RubyGems): affected all versions; fixed in 3.9.0
- secure_headers (RubyGems): affected all versions; fixed in 3.9.0
- secure_headers (RubyGems): affected from 5.0.0; fixed in 5.2.0
- secure_headers (RubyGems): affected from 5.0.0; fixed in 5.2.0
- secure_headers (RubyGems): affected from 6.0.0; fixed in 6.3.0
- secure_headers (RubyGems): affected from 6.0.0; fixed in 6.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5216/ (Markdown: https://insights.sbomify.com/CVE-2020-5216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5216
- OSV: https://osv.dev/vulnerability/CVE-2020-5216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5216/
Summaries are generated and may contain mistakes; the official description above is the record.
