CVE-2020-5217 Directive injection when using dynamic overrides with user input in RubyGems secure_headers
Attackers can inject semicolons into Content Security Policy directives via user input, potentially overriding security restrictions in applications using the secure_headers Ruby gem.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-5217?
CVE-2020-5217 is a medium-severity code injection vulnerability in Twitter secure_headers, published on 23 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.8.0, 5.1.0, and 6.2.0. If user-supplied input was passed into append/override_content_security_policy_directives, a semicolon could be injected leading to directive injection. This could be used to e.g. override a script-src directive. Duplicate directives are ignored and the first one wins. The directives in secure_headers are sorted alphabetically so they pretty much all come before script-src. A previously undefined directive would receive a value even if SecureHeaders::OPT_OUT was supplied. The fixed versions will silently convert the semicolons to spaces and emit a deprecation warning when this happens. This will result in innocuous browser console messages if being exploited/accidentally used. In future releases, we will raise application errors resulting in 500s. Depending on what major version you are using, the fixed versions are 6.2.0, 5.1.0, 3.8.0.
Which versions are affected by CVE-2020-5217?
6 open source packages ship an affected version, including secure_headers. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
secure_headers RubyGems | All versions | 3.8.0 |
secure_headers RubyGems | All versions | 3.8.0 |
secure_headers RubyGems | From 5.0.0 | 5.1.0 |
secure_headers RubyGems | From 5.0.0 | 5.1.0 |
secure_headers RubyGems | From 6.0.0 | 6.2.0 |
secure_headers RubyGems | From 6.0.0 | 6.2.0 |
Products include Twitter Secure Headers.
How do I fix CVE-2020-5217?
Upgrade secure_headers to a fixed version for your release line: 3.8.0, 5.1.0 or 6.2.0.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2020-5217 being exploited?
There is no known exploitation of CVE-2020-5217 in the wild and no public exploit code.
Other vulnerabilities in Twitter secure_headers
Sources
Also known as DEBIAN-CVE-2020-5217, GHSA-xq52-rv6w-397c, UBUNTU-CVE-2020-5217.