# CVE-2020-5217: Directive injection when using dynamic overrides with user input in RubyGems secure_headers

> Attackers can inject semicolons into Content Security Policy directives via user input, potentially overriding security restrictions in applications using the secure_headers Ruby gem.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-5217, GHSA-xq52-rv6w-397c, UBUNTU-CVE-2020-5217

## What is CVE-2020-5217?

CVE-2020-5217 is a medium-severity code injection vulnerability in Twitter secure_headers, published on 23 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Secure Headers (RubyGem secure_headers), a directive injection vulnerability is present in versions before 3.8.0, 5.1.0, and 6.2.0. If user-supplied input was passed into append/override_content_security_policy_directives, a semicolon could be injected leading to directive injection. This could be used to e.g. override a script-src directive. Duplicate directives are ignored and the first one wins. The directives in secure_headers are sorted alphabetically so they pretty much all come before script-src. A previously undefined directive would receive a value even if SecureHeaders::OPT_OUT was supplied. The fixed versions will silently convert the semicolons to spaces and emit a deprecation warning when this happens. This will result in innocuous browser console messages if being exploited/accidentally used. In future releases, we will raise application errors resulting in 500s. Depending on what major version you are using, the fixed versions are 6.2.0, 5.1.0, 3.8.0.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2020-5217?

6 open source packages ship an affected version, including secure_headers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `secure_headers` | RubyGems | All versions | 3.8.0 |
| `secure_headers` | RubyGems | All versions | 3.8.0 |
| `secure_headers` | RubyGems | From 5.0.0 | 5.1.0 |
| `secure_headers` | RubyGems | From 5.0.0 | 5.1.0 |
| `secure_headers` | RubyGems | From 6.0.0 | 6.2.0 |
| `secure_headers` | RubyGems | From 6.0.0 | 6.2.0 |

Products: Twitter Secure Headers.

## How do I fix CVE-2020-5217?

Upgrade secure_headers to a fixed version for your release line: 3.8.0, 5.1.0 or 6.2.0.

## Is CVE-2020-5217 being exploited?

There is no known exploitation of CVE-2020-5217 in the wild and no public exploit code.

## Other vulnerabilities in Twitter secure_headers

- [CVE-2020-5216](https://insights.sbomify.com/CVE-2020-5216/): Limited header injection when using dynamic overrides with user input in RubyGems secure_headers (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5217 and fix it if it is affected.

What it is: CVE-2020-5217 is a medium-severity code injection vulnerability in Twitter secure_headers, published on 23 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5217 in the wild and no public exploit code.

Affected packages and fixed versions:
- secure_headers (RubyGems): affected all versions; fixed in 3.8.0
- secure_headers (RubyGems): affected all versions; fixed in 3.8.0
- secure_headers (RubyGems): affected from 5.0.0; fixed in 5.1.0
- secure_headers (RubyGems): affected from 5.0.0; fixed in 5.1.0
- secure_headers (RubyGems): affected from 6.0.0; fixed in 6.2.0
- secure_headers (RubyGems): affected from 6.0.0; fixed in 6.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5217/ (Markdown: https://insights.sbomify.com/CVE-2020-5217/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5217
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5217
- OSV: https://osv.dev/vulnerability/CVE-2020-5217

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5217/
Summaries are generated and may contain mistakes; the official description above is the record.
