# CVE-2020-5224: Session key exposure through session list in Django User Sessions

> Attackers can steal session keys from rendered HTML if an XSS vulnerability exists, leading to account takeover in Django applications using this library.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5fq8-3q2f-4m5g, PYSEC-2020-230

## What is CVE-2020-5224?

CVE-2020-5224 is a medium-severity vulnerability in Jazzband django-user-sessions, published on 24 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Django User Sessions (django-user-sessions) before 1.7.1, the views provided allow users to terminate specific sessions. The session key is used to identify sessions, and thus included in the rendered HTML. In itself this is not a problem. However if the website has an XSS vulnerability, the session key could be extracted by the attacker and a session takeover could happen.

Weakness: CWE-326 (Inadequate Encryption Strength), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2020-5224?

3 open source packages ship an affected version, including django-user-sessions. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django-user-sessions` | PyPI | All versions | 1.7.1 |
| `django-user-sessions` | PyPI | All versions | 1.7.1 |
| `django-user-sessions` | PyPI | All versions | 1.7.1 |

Products: Django-User-Sessions Project Django-User-Sessions.

## How do I fix CVE-2020-5224?

Upgrade django-user-sessions to 1.7.1 or later.

## Is CVE-2020-5224 being exploited?

There is no known exploitation of CVE-2020-5224 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5224 and fix it if it is affected.

What it is: CVE-2020-5224 is a medium-severity vulnerability in Jazzband django-user-sessions, published on 24 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5224 in the wild and no public exploit code.

Affected packages and fixed versions:
- django-user-sessions (PyPI): affected all versions; fixed in 1.7.1
- django-user-sessions (PyPI): affected all versions; fixed in 1.7.1
- django-user-sessions (PyPI): affected all versions; fixed in 1.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5224/ (Markdown: https://insights.sbomify.com/CVE-2020-5224/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5224
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5224
- OSV: https://osv.dev/vulnerability/CVE-2020-5224

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5224/
Summaries are generated and may contain mistakes; the official description above is the record.
