# CVE-2020-5226: Cross-site scripting in SimpleSAMLphp

> Attackers can inject HTML into error report emails via unescaped fields when using the legacy PHP template, potentially leading to XSS.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-5226, GHSA-mj9p-v2r8-wf8w

## What is CVE-2020-5226?

CVE-2020-5226 is a medium-severity cross-site scripting vulnerability in SimpleSAMLphp, published on 24 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting in SimpleSAMLphp before version 1.18.4. The www/erroreport.php script allows error reports to be submitted and sent to the system administrator. Starting with SimpleSAMLphp 1.18.0, a new SimpleSAML\Utils\EMail class was introduced to handle sending emails, implemented as a wrapper of an external dependency. This new wrapper allows us to use Twig templates in order to create the email sent with an error report. Since Twig provides automatic escaping of variables, manual escaping of the free-text field in www/errorreport.php was removed to avoid double escaping. However, for those not using the new user interface yet, an email template is hardcoded into the class itself in plain PHP. Since no escaping is provided in this template, it is then possible to inject HTML inside the template by manually crafting the contents of the free-text field.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-5226?

2 open source packages ship an affected version, including simplesamlphp/simplesamlphp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `simplesamlphp/simplesamlphp` | Packagist | From 1.18.0 | 1.18.4 |
| `simplesamlphp/simplesamlphp` | Packagist | From 1.18.0 | 1.18.4 |

Products: Simplesamlphp Simplesamlphp.

## How do I fix CVE-2020-5226?

Upgrade simplesamlphp/simplesamlphp to 1.18.4 or later.

## Is CVE-2020-5226 being exploited?

There is no known exploitation of CVE-2020-5226 in the wild and no public exploit code.

## Other vulnerabilities in SimpleSAMLphp

- [CVE-2017-12868](https://insights.sbomify.com/CVE-2017-12868/): SimpleSAMLphp Session fixation issue and authentication bypass in the authcrypt module (critical 9.8)
- [CVE-2018-7644](https://insights.sbomify.com/CVE-2018-7644/): SimpleSAMLphp Improper Verification of Cryptographic Signature (high 7.5)
- [CVE-2026-49284](https://insights.sbomify.com/CVE-2026-49284/): SimpleSAMLphp SP accepts a response from an unexpected IdP when unsigned `Response/InResponseTo` is combined with a signed assertion lacking `SubjectConfirmationData/InResponseTo` (high 7.1)
- [CVE-2018-6520](https://insights.sbomify.com/CVE-2018-6520/): SimpleSAMLphp Open redirection protection bypass (medium 6.1)
- [CVE-2017-12870](https://insights.sbomify.com/CVE-2017-12870/): SimpleSAMLphp Unauthenticated encryption in CBC mode (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5226 and fix it if it is affected.

What it is: CVE-2020-5226 is a medium-severity cross-site scripting vulnerability in SimpleSAMLphp, published on 24 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5226 in the wild and no public exploit code.

Affected packages and fixed versions:
- simplesamlphp/simplesamlphp (Packagist): affected from 1.18.0; fixed in 1.18.4
- simplesamlphp/simplesamlphp (Packagist): affected from 1.18.0; fixed in 1.18.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5226/ (Markdown: https://insights.sbomify.com/CVE-2020-5226/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5226
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5226
- OSV: https://osv.dev/vulnerability/CVE-2020-5226

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5226/
Summaries are generated and may contain mistakes; the official description above is the record.
