{"answers":{"affected":"3 open source packages ship an affected version, including feedgen. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-5227 in the wild and no public exploit code.","fix":"Upgrade feedgen to 0.9.0 or later.","what":"CVE-2020-5227 is a medium-severity denial of service vulnerability in lkiesow python-feedgen, published on 28 Jan 2020. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-5227 and fix it if it is affected.\n\nWhat it is: CVE-2020-5227 is a medium-severity denial of service vulnerability in lkiesow python-feedgen, published on 28 Jan 2020. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-5227 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- feedgen (PyPI): affected all versions; fixed in 0.9.0\n- feedgen (PyPI): affected all versions; fixed in 0.9.0\n- feedgen (PyPI): affected all versions; fixed in 0.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-5227/ (Markdown: https://insights.sbomify.com/CVE-2020-5227/index.md)","id":"CVE-2020-5227","markdown":"https://insights.sbomify.com/CVE-2020-5227/index.md","name":"CVE-2020-5227","record":{"aliases":["GHSA-g8q7-xv52-hf9f","PYSEC-2020-231"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python feed generation library","requires_auth":"high_privilege","summary":"Attackers can cause denial of service in applications using feedgen by supplying malicious XML content that triggers excessive resource consumption.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"feedgen","vendor":"feedgen_project"}],"cvss":{"score":4.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-776","name":"Improper Restriction of Recursive Entity References in DTDs"}],"description":"Feedgen (python feedgen) before 0.9.0 is susceptible to XML Denial of Service attacks. The *feedgen* library allows supplying XML as content for some of the available fields. This XML will be parsed and integrated into the existing XML tree. During this process, feedgen is vulnerable to XML Denial of Service Attacks (e.g. XML Bomb). This becomes a concern in particular if feedgen is used to include content from untrused sources and if XML (including XHTML) is directly included instead of providing plain tex content only. This problem has been fixed in feedgen 0.9.0 which disallows XML entity expansion and external resources.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Feedgen Vulnerable to XML Denial of Service Attacks","id":"CVE-2020-5227","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":3,"n_references":4,"next":{"headline":"Opencast allows unauthorized public access via OAI-PMH","id":"CVE-2020-5228"},"packages":[{"ecosystem":"PyPI","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"feedgen","purl":null,"source":"GHSA-g8q7-xv52-hf9f"},{"ecosystem":"PyPI","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"feedgen","purl":"pkg:pypi/feedgen","source":"GHSA-g8q7-xv52-hf9f"},{"ecosystem":"PyPI","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"feedgen","purl":"pkg:pypi/feedgen","source":"PYSEC-2020-231"}],"prev":{"headline":"Cross-site scripting in SimpleSAMLphp","id":"CVE-2020-5226"},"products":["python-feedgen"],"published":"2020-01-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["lkiesow"]},"summary":"Attackers can cause denial of service in applications using feedgen by supplying malicious XML content that triggers excessive resource consumption.","url":"https://insights.sbomify.com/CVE-2020-5227/"}