# CVE-2020-5227: Feedgen Vulnerable to XML Denial of Service Attacks

> Attackers can cause denial of service in applications using feedgen by supplying malicious XML content that triggers excessive resource consumption.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-g8q7-xv52-hf9f, PYSEC-2020-231

## What is CVE-2020-5227?

CVE-2020-5227 is a medium-severity denial of service vulnerability in lkiesow python-feedgen, published on 28 Jan 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Feedgen (python feedgen) before 0.9.0 is susceptible to XML Denial of Service attacks. The *feedgen* library allows supplying XML as content for some of the available fields. This XML will be parsed and integrated into the existing XML tree. During this process, feedgen is vulnerable to XML Denial of Service Attacks (e.g. XML Bomb). This becomes a concern in particular if feedgen is used to include content from untrused sources and if XML (including XHTML) is directly included instead of providing plain tex content only. This problem has been fixed in feedgen 0.9.0 which disallows XML entity expansion and external resources.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs)

## Which versions are affected by CVE-2020-5227?

3 open source packages ship an affected version, including feedgen. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `feedgen` | PyPI | All versions | 0.9.0 |
| `feedgen` | PyPI | All versions | 0.9.0 |
| `feedgen` | PyPI | All versions | 0.9.0 |

Products: Feedgen Project Feedgen.

## How do I fix CVE-2020-5227?

Upgrade feedgen to 0.9.0 or later.

## Is CVE-2020-5227 being exploited?

There is no known exploitation of CVE-2020-5227 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5227 and fix it if it is affected.

What it is: CVE-2020-5227 is a medium-severity denial of service vulnerability in lkiesow python-feedgen, published on 28 Jan 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-5227 in the wild and no public exploit code.

Affected packages and fixed versions:
- feedgen (PyPI): affected all versions; fixed in 0.9.0
- feedgen (PyPI): affected all versions; fixed in 0.9.0
- feedgen (PyPI): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5227/ (Markdown: https://insights.sbomify.com/CVE-2020-5227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5227
- OSV: https://osv.dev/vulnerability/CVE-2020-5227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5227/
Summaries are generated and may contain mistakes; the official description above is the record.
