# CVE-2020-5229: Opencast stores passwords using outdated MD5 hash algorithm

> Opencast uses insecure MD5 hashing with predictable salts, allowing attackers with database access to potentially recover user passwords.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-h362-m8f2-5x7c

## What is CVE-2020-5229?

CVE-2020-5229 is a high-severity vulnerability in opencast, published on 30 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Opencast before 8.1 stores passwords using the rather outdated and cryptographically insecure MD5 hash algorithm. Furthermore, the hashes are salted using the username instead of a random salt, causing hashes for users with the same username and password to collide which is problematic especially for popular users like the default `admin` user. This essentially means that for an attacker, it might be feasible to reconstruct a user's password given access to these hashes. Note that attackers needing access to the hashes means that they must gain access to the database in which these are stored first to be able to start cracking the passwords. The problem is addressed in Opencast 8.1 which now uses the modern and much stronger bcrypt password hashing algorithm for storing passwords. Note, that old hashes remain MD5 until the password is updated. For a list of users whose password hashes are stored using MD5, take a look at the `/user-utils/users/md5.json` REST endpoint.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2020-5229?

4 open source packages ship an affected version, including org.opencastproject:opencast-common-jpa-impl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencastproject:opencast-common-jpa-impl` | Maven | All versions | 7.6 |
| `org.opencastproject:opencast-common-jpa-impl` | Maven | All versions | 7.6 |
| `org.opencastproject:opencast-common-jpa-impl` | Maven | From 8.0 | 8.1 |
| `org.opencastproject:opencast-common-jpa-impl` | Maven | From 8.0 | 8.1 |

Products: Apereo Opencast.

## How do I fix CVE-2020-5229?

Upgrade org.opencastproject:opencast-common-jpa-impl to a fixed version for your release line: 7.6 or 8.1.

## Is CVE-2020-5229 being exploited?

There is no known exploitation of CVE-2020-5229 in the wild and no public exploit code.

## Other vulnerabilities in opencast

- [CVE-2021-43821](https://insights.sbomify.com/CVE-2021-43821/): Files Accessible to External Parties in Opencast (critical 9.9)
- [CVE-2020-5206](https://insights.sbomify.com/CVE-2020-5206/): Authentication Bypass For Endpoints With Anonymous Access in OpenCast (high 8.7)
- [CVE-2021-32623](https://insights.sbomify.com/CVE-2021-32623/): Opencast vulnerable to billion laughs attack (XML bomb) (high 8.1)
- [CVE-2020-5230](https://insights.sbomify.com/CVE-2020-5230/): Opencast uses unsafe identifiers (high 7.7)
- [CVE-2020-5228](https://insights.sbomify.com/CVE-2020-5228/): Opencast allows unauthorized public access via OAI-PMH (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5229 and fix it if it is affected.

What it is: CVE-2020-5229 is a high-severity vulnerability in opencast, published on 30 Jan 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5229 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencastproject:opencast-common-jpa-impl (Maven): affected all versions; fixed in 7.6
- org.opencastproject:opencast-common-jpa-impl (Maven): affected all versions; fixed in 7.6
- org.opencastproject:opencast-common-jpa-impl (Maven): affected from 8.0; fixed in 8.1
- org.opencastproject:opencast-common-jpa-impl (Maven): affected from 8.0; fixed in 8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5229/ (Markdown: https://insights.sbomify.com/CVE-2020-5229/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5229
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5229
- OSV: https://osv.dev/vulnerability/CVE-2020-5229

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5229/
Summaries are generated and may contain mistakes; the official description above is the record.
