# CVE-2020-5231: Opencast users with ROLE_COURSE_ADMIN can create new users

> Users with the non-standard ROLE_COURSE_ADMIN can create new users, leading to unauthorized privilege escalation and data modification.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jan 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-94qw-r73x-j7hg

## What is CVE-2020-5231?

CVE-2020-5231 is a medium-severity missing authorization vulnerability in opencast, published on 30 Jan 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

In Opencast before 7.6 and 8.1, users with the role ROLE_COURSE_ADMIN can use the user-utils endpoint to create new users not including the role ROLE_ADMIN. ROLE_COURSE_ADMIN is a non-standard role in Opencast which is referenced neither in the documentation nor in any code (except for tests) but only in the security configuration. From the name – implying an admin for a specific course – users would never expect that this role allows user creation. This issue is fixed in 7.6 and 8.1 which both ship a new default security configuration.

Weakness: CWE-276 (Incorrect Default Permissions), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2020-5231?

4 open source packages ship an affected version, including org.opencastproject:opencast-kernel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencastproject:opencast-kernel` | Maven | All versions | 7.6 |
| `org.opencastproject:opencast-kernel` | Maven | All versions | 7.6 |
| `org.opencastproject:opencast-kernel` | Maven | From 8.0 | 8.1 |
| `org.opencastproject:opencast-kernel` | Maven | From 8.0 | 8.1 |

Products: Apereo Opencast.

## How do I fix CVE-2020-5231?

Upgrade org.opencastproject:opencast-kernel to a fixed version for your release line: 7.6 or 8.1.

## Is CVE-2020-5231 being exploited?

There is no known exploitation of CVE-2020-5231 in the wild and no public exploit code.

## Other vulnerabilities in opencast

- [CVE-2021-43821](https://insights.sbomify.com/CVE-2021-43821/): Files Accessible to External Parties in Opencast (critical 9.9)
- [CVE-2020-5206](https://insights.sbomify.com/CVE-2020-5206/): Authentication Bypass For Endpoints With Anonymous Access in OpenCast (high 8.7)
- [CVE-2021-32623](https://insights.sbomify.com/CVE-2021-32623/): Opencast vulnerable to billion laughs attack (XML bomb) (high 8.1)
- [CVE-2020-5229](https://insights.sbomify.com/CVE-2020-5229/): Opencast stores passwords using outdated MD5 hash algorithm (high 7.7)
- [CVE-2020-5230](https://insights.sbomify.com/CVE-2020-5230/): Opencast uses unsafe identifiers (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5231 and fix it if it is affected.

What it is: CVE-2020-5231 is a medium-severity missing authorization vulnerability in opencast, published on 30 Jan 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5231 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opencastproject:opencast-kernel (Maven): affected all versions; fixed in 7.6
- org.opencastproject:opencast-kernel (Maven): affected all versions; fixed in 7.6
- org.opencastproject:opencast-kernel (Maven): affected from 8.0; fixed in 8.1
- org.opencastproject:opencast-kernel (Maven): affected from 8.0; fixed in 8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5231/ (Markdown: https://insights.sbomify.com/CVE-2020-5231/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5231
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5231
- OSV: https://osv.dev/vulnerability/CVE-2020-5231

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5231/
Summaries are generated and may contain mistakes; the official description above is the record.
