{"answers":{"affected":"4 open source packages ship an affected version, including oneup/uploader-bundle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-5237 in the wild and no public exploit code.","fix":"Upgrade oneup/uploader-bundle to a fixed version for your release line: 1.9.3 or 2.1.5.","what":"CVE-2020-5237 is a high-severity path traversal vulnerability in 1up-lab oneup/uploader-bundle, published on 5 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-5237 and fix it if it is affected.\n\nWhat it is: CVE-2020-5237 is a high-severity path traversal vulnerability in 1up-lab oneup/uploader-bundle, published on 5 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-5237 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- oneup/uploader-bundle (Packagist): affected from 1.0.0; fixed in 1.9.3\n- oneup/uploader-bundle (Packagist): affected from 1.0.0; fixed in 1.9.3\n- oneup/uploader-bundle (Packagist): affected from 2.0.0; fixed in 2.1.5\n- oneup/uploader-bundle (Packagist): affected from 2.0.0; fixed in 2.1.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-5237/ (Markdown: https://insights.sbomify.com/CVE-2020-5237/index.md)","id":"CVE-2020-5237","markdown":"https://insights.sbomify.com/CVE-2020-5237/index.md","name":"CVE-2020-5237","record":{"aliases":["GHSA-x8wj-6m73-gfqp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP uploader bundle","requires_auth":"low_privilege","summary":"Remote attackers can exploit relative path traversal to upload, copy, or modify files, potentially leading to arbitrary code execution.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"oneupuploaderbundle","vendor":"1up"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"},{"id":"CWE-23","name":"Relative Path Traversal"}],"description":"Multiple relative path traversal vulnerabilities in the oneup/uploader-bundle before 1.9.3 and 2.1.5 allow remote attackers to upload, copy, and modify files on the filesystem (potentially leading to arbitrary code execution) via the (1) filename parameter to BlueimpController.php; the (2) dzchunkindex, (3) dzuuid, or (4) filename parameter to DropzoneController.php; the (5) qqpartindex, (6) qqfilename, or (7) qquuid parameter to FineUploaderController.php; the (8) x-file-id or (9) x-file-name parameter to MooUploadController.php; or the (10) name or (11) chunk parameter to PluploadController.php. This is fixed in versions 1.9.3 and 2.1.5.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Relative Path Traversal in oneup/uploader-bundle","id":"CVE-2020-5237","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2020"},"n_packages":4,"n_references":3,"next":{"headline":"Denial of service in table parsing in cmark-gfm","id":"CVE-2020-5238"},"packages":[{"ecosystem":"Packagist","fixed":["1.9.3"],"introduced":["1.0.0"],"last_affected":[],"package":"oneup/uploader-bundle","purl":null,"source":"GHSA-x8wj-6m73-gfqp"},{"ecosystem":"Packagist","fixed":["1.9.3"],"introduced":["1.0.0"],"last_affected":[],"package":"oneup/uploader-bundle","purl":"pkg:composer/oneup/uploader-bundle","source":"GHSA-x8wj-6m73-gfqp"},{"ecosystem":"Packagist","fixed":["2.1.5"],"introduced":["2.0.0"],"last_affected":[],"package":"oneup/uploader-bundle","purl":null,"source":"GHSA-x8wj-6m73-gfqp"},{"ecosystem":"Packagist","fixed":["2.1.5"],"introduced":["2.0.0"],"last_affected":[],"package":"oneup/uploader-bundle","purl":"pkg:composer/oneup/uploader-bundle","source":"GHSA-x8wj-6m73-gfqp"}],"prev":{"headline":"Catastrophic backtracking in regex allows Denial of Service in Waitress","id":"CVE-2020-5236"},"products":["oneup/uploader-bundle"],"published":"2020-02-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["1up-lab"]},"summary":"Remote attackers can exploit relative path traversal to upload, copy, or modify files, potentially leading to arbitrary code execution.","url":"https://insights.sbomify.com/CVE-2020-5237/"}