# CVE-2020-5237: Relative Path Traversal in oneup/uploader-bundle

> Remote attackers can exploit relative path traversal to upload, copy, or modify files, potentially leading to arbitrary code execution.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-x8wj-6m73-gfqp

## What is CVE-2020-5237?

CVE-2020-5237 is a high-severity path traversal vulnerability in 1up-lab oneup/uploader-bundle, published on 5 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Multiple relative path traversal vulnerabilities in the oneup/uploader-bundle before 1.9.3 and 2.1.5 allow remote attackers to upload, copy, and modify files on the filesystem (potentially leading to arbitrary code execution) via the (1) filename parameter to BlueimpController.php; the (2) dzchunkindex, (3) dzuuid, or (4) filename parameter to DropzoneController.php; the (5) qqpartindex, (6) qqfilename, or (7) qquuid parameter to FineUploaderController.php; the (8) x-file-id or (9) x-file-name parameter to MooUploadController.php; or the (10) name or (11) chunk parameter to PluploadController.php. This is fixed in versions 1.9.3 and 2.1.5.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2020-5237?

4 open source packages ship an affected version, including oneup/uploader-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oneup/uploader-bundle` | Packagist | From 1.0.0 | 1.9.3 |
| `oneup/uploader-bundle` | Packagist | From 1.0.0 | 1.9.3 |
| `oneup/uploader-bundle` | Packagist | From 2.0.0 | 2.1.5 |
| `oneup/uploader-bundle` | Packagist | From 2.0.0 | 2.1.5 |

Products: 1up Oneupuploaderbundle.

## How do I fix CVE-2020-5237?

Upgrade oneup/uploader-bundle to a fixed version for your release line: 1.9.3 or 2.1.5.

## Is CVE-2020-5237 being exploited?

There is no known exploitation of CVE-2020-5237 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5237 and fix it if it is affected.

What it is: CVE-2020-5237 is a high-severity path traversal vulnerability in 1up-lab oneup/uploader-bundle, published on 5 Feb 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-5237 in the wild and no public exploit code.

Affected packages and fixed versions:
- oneup/uploader-bundle (Packagist): affected from 1.0.0; fixed in 1.9.3
- oneup/uploader-bundle (Packagist): affected from 1.0.0; fixed in 1.9.3
- oneup/uploader-bundle (Packagist): affected from 2.0.0; fixed in 2.1.5
- oneup/uploader-bundle (Packagist): affected from 2.0.0; fixed in 2.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5237/ (Markdown: https://insights.sbomify.com/CVE-2020-5237/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5237
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5237
- OSV: https://osv.dev/vulnerability/CVE-2020-5237

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5237/
Summaries are generated and may contain mistakes; the official description above is the record.
