# CVE-2020-5240: 2FA bypass through deleting devices in wagtail-2fa

> Attackers can delete other users' 2FA devices without permission, potentially enabling account takeover if passwords are known.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9gjv-6qq6-v7qm, PYSEC-2020-219

## What is CVE-2020-5240?

CVE-2020-5240 is a high-severity missing authorization vulnerability in Lab Digital wagtail-2fa, published on 13 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In wagtail-2fa before 1.4.1, any user with access to the CMS can view and delete other users 2FA devices by going to the correct path. The user does not require special permissions in order to do so. By deleting the other users device they can disable the target users 2FA devices and potentially compromise the account if they figure out their password. The problem has been patched in version 1.4.1.

Weakness: CWE-863 (Incorrect Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2020-5240?

3 open source packages ship an affected version, including wagtail-2fa. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wagtail-2fa` | PyPI | All versions | 1.4.1 |
| `wagtail-2fa` | PyPI | All versions | 1.4.1 |
| `wagtail-2fa` | PyPI | All versions | 1.4.1 |

Products: Labdigital Wagtail-2fa.

## How do I fix CVE-2020-5240?

Upgrade wagtail-2fa to 1.4.1 or later.

## Is CVE-2020-5240 being exploited?

There is no known exploitation of CVE-2020-5240 in the wild and no public exploit code.

## Other vulnerabilities in Lab Digital wagtail-2fa

- [CVE-2019-16766](https://insights.sbomify.com/CVE-2019-16766/): 2FA bypass in Wagtail through new device path (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5240 and fix it if it is affected.

What it is: CVE-2020-5240 is a high-severity missing authorization vulnerability in Lab Digital wagtail-2fa, published on 13 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5240 in the wild and no public exploit code.

Affected packages and fixed versions:
- wagtail-2fa (PyPI): affected all versions; fixed in 1.4.1
- wagtail-2fa (PyPI): affected all versions; fixed in 1.4.1
- wagtail-2fa (PyPI): affected all versions; fixed in 1.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5240/ (Markdown: https://insights.sbomify.com/CVE-2020-5240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5240
- OSV: https://osv.dev/vulnerability/CVE-2020-5240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5240/
Summaries are generated and may contain mistakes; the official description above is the record.
