{"answers":{"affected":"4 open source packages ship an affected version, including uap-core and user_agent_parser. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-5243 in the wild and no public exploit code.","fix":"Upgrade uap-core to 0.7.3 or later.","what":"CVE-2020-5243 is a medium-severity denial of service vulnerability in ua-parser uap-core, published on 20 Feb 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-5243 and fix it if it is affected.\n\nWhat it is: CVE-2020-5243 is a medium-severity denial of service vulnerability in ua-parser uap-core, published on 20 Feb 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-5243 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uap-core (npm): affected all versions; fixed in 0.7.3\n- uap-core (npm): affected all versions; fixed in 0.7.3\n- user_agent_parser (RubyGems): affected all versions; fixed in 2.6.0\n- user_agent_parser (RubyGems): affected all versions; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-5243/ (Markdown: https://insights.sbomify.com/CVE-2020-5243/index.md)","id":"CVE-2020-5243","markdown":"https://insights.sbomify.com/CVE-2020-5243/index.md","name":"CVE-2020-5243","record":{"aliases":["DEBIAN-CVE-2020-5243","GHSA-cmcx-xhr8-3w9p","UBUNTU-CVE-2020-5243"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"User-Agent parsing library","requires_auth":"low_privilege","summary":"Remote attackers can cause denial of service in uap-core by sending crafted User-Agent strings that trigger excessive CPU usage via regex backtracking.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"uap-core","vendor":"uap-core_project"}],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"uap-core before 0.7.3 is vulnerable to a denial of service attack when processing crafted User-Agent strings. Some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. This has been patched in uap-core 0.7.3.","ecosystems":["RubyGems","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in uap-core when processing crafted User-Agent strings","id":"CVE-2020-5243","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2020"},"n_packages":4,"n_references":2,"next":{"headline":"Private data exposure via REST API in BuddyPress","id":"CVE-2020-5244"},"packages":[{"ecosystem":"RubyGems","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"user_agent_parser","purl":null,"source":"GHSA-cmcx-xhr8-3w9p"},{"ecosystem":"RubyGems","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"user_agent_parser","purl":"pkg:gem/user_agent_parser","source":"GHSA-cmcx-xhr8-3w9p"},{"ecosystem":"npm","fixed":["0.7.3"],"introduced":["0"],"last_affected":[],"package":"uap-core","purl":null,"source":"GHSA-cmcx-xhr8-3w9p"},{"ecosystem":"npm","fixed":["0.7.3"],"introduced":["0"],"last_affected":[],"package":"uap-core","purl":"pkg:npm/uap-core","source":"GHSA-cmcx-xhr8-3w9p"}],"prev":{"headline":"openHAB exec add-ons allow remote arbitrary command execution","id":"CVE-2020-5242"},"products":["uap-core"],"published":"2020-02-20","related":[{"cvss_score":5.3,"headline":"Denial of Service in uap-core","id":"CVE-2021-21317","kev_date_added":null,"published":"2021-02-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["ua-parser"]},"summary":"Remote attackers can cause denial of service in uap-core by sending crafted User-Agent strings that trigger excessive CPU usage via regex backtracking.","url":"https://insights.sbomify.com/CVE-2020-5243/"}