{"answers":{"affected":"2 open source packages ship an affected version, including buddypress/buddypress. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-5244 in the wild and no public exploit code.","fix":"Upgrade buddypress/buddypress to 5.1.2 or later.","what":"CVE-2020-5244 is a high-severity vulnerability in BuddyPress, published on 24 Feb 2020."},"fix_prompt":"Check this codebase for CVE-2020-5244 and fix it if it is affected.\n\nWhat it is: CVE-2020-5244 is a high-severity vulnerability in BuddyPress, published on 24 Feb 2020. \nExploitation: There is no known exploitation of CVE-2020-5244 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- buddypress/buddypress (Packagist): affected all versions; fixed in 5.1.2\n- buddypress/buddypress (Packagist): affected all versions; fixed in 5.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-5244/ (Markdown: https://insights.sbomify.com/CVE-2020-5244/index.md)","id":"CVE-2020-5244","markdown":"https://insights.sbomify.com/CVE-2020-5244/index.md","name":"CVE-2020-5244","record":{"aliases":["GHSA-3j78-7m59-r7gv"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"buddypress","vendor":"buddypress"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"},{"id":"CWE-284","name":"Improper Access Control"}],"description":"In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed. This has been patched in version 5.1.2.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Private data exposure via REST API in BuddyPress","id":"CVE-2020-5244","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":null,"year":"2020"},"n_packages":2,"n_references":3,"next":{"headline":"Remote Code Execution (RCE) vulnerability in dropwizard-validation","id":"CVE-2020-5245"},"packages":[{"ecosystem":"Packagist","fixed":["5.1.2"],"introduced":["0"],"last_affected":[],"package":"buddypress/buddypress","purl":null,"source":"GHSA-3j78-7m59-r7gv"},{"ecosystem":"Packagist","fixed":["5.1.2"],"introduced":["0"],"last_affected":[],"package":"buddypress/buddypress","purl":"pkg:composer/buddypress/buddypress","source":"GHSA-3j78-7m59-r7gv"}],"prev":{"headline":"Denial of Service in uap-core when processing crafted User-Agent strings","id":"CVE-2020-5243"},"products":["BuddyPress"],"published":"2020-02-24","related":[{"cvss_score":8.1,"headline":"BuddyPress \u003c= 14.1.0 - Authenticated (Subscriber+) Directory Traversal","id":"CVE-2024-10011","kev_date_added":null,"published":"2024-10-25"},{"cvss_score":8.1,"headline":"BuddyPress privilege escalation via REST API","id":"CVE-2021-21389","kev_date_added":null,"published":"2021-03-26"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2012-2109","kev_date_added":null,"published":"2012-09-04"},{"cvss_score":7.1,"headline":"WordPress Mass Messaging in BuddyPress Plugin \u003c= 2.2.1 - Reflected Cross Site Scripting (XSS) vulnerability","id":"CVE-2025-23798","kev_date_added":null,"published":"2025-01-22"},{"cvss_score":6.5,"headline":"WordPress BuddyPress Plugin \u003c= 11.3.1 is vulnerable to Cross Site Scripting (XSS)","id":"CVE-2023-50880","kev_date_added":null,"published":"2023-12-29"},{"cvss_score":6.5,"headline":"Missing authorization in n/a","id":"CVE-2014-1889","kev_date_added":null,"published":"2018-04-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["buddypress"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2020-5244/"}