# CVE-2020-5244: Private data exposure via REST API in BuddyPress


- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 24 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-3j78-7m59-r7gv

## What is CVE-2020-5244?

CVE-2020-5244 is a high-severity vulnerability in BuddyPress, published on 24 Feb 2020. 

### Official description

In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed. This has been patched in version 5.1.2.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2020-5244?

2 open source packages ship an affected version, including buddypress/buddypress. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `buddypress/buddypress` | Packagist | All versions | 5.1.2 |
| `buddypress/buddypress` | Packagist | All versions | 5.1.2 |

Products: Buddypress Buddypress.

## How do I fix CVE-2020-5244?

Upgrade buddypress/buddypress to 5.1.2 or later.

## Is CVE-2020-5244 being exploited?

There is no known exploitation of CVE-2020-5244 in the wild and no public exploit code.

## Other vulnerabilities in BuddyPress

- [CVE-2024-10011](https://insights.sbomify.com/CVE-2024-10011/): BuddyPress <= 14.1.0 - Authenticated (Subscriber+) Directory Traversal (high 8.1)
- [CVE-2021-21389](https://insights.sbomify.com/CVE-2021-21389/): BuddyPress privilege escalation via REST API (high 8.1)
- [CVE-2012-2109](https://insights.sbomify.com/CVE-2012-2109/): SQL injection in n/a (high 7.5)
- [CVE-2025-23798](https://insights.sbomify.com/CVE-2025-23798/): WordPress Mass Messaging in BuddyPress Plugin <= 2.2.1 - Reflected Cross Site Scripting (XSS) vulnerability (high 7.1)
- [CVE-2023-50880](https://insights.sbomify.com/CVE-2023-50880/): WordPress BuddyPress Plugin <= 11.3.1 is vulnerable to Cross Site Scripting (XSS) (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5244 and fix it if it is affected.

What it is: CVE-2020-5244 is a high-severity vulnerability in BuddyPress, published on 24 Feb 2020. 
Exploitation: There is no known exploitation of CVE-2020-5244 in the wild and no public exploit code.

Affected packages and fixed versions:
- buddypress/buddypress (Packagist): affected all versions; fixed in 5.1.2
- buddypress/buddypress (Packagist): affected all versions; fixed in 5.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5244/ (Markdown: https://insights.sbomify.com/CVE-2020-5244/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5244
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5244
- OSV: https://osv.dev/vulnerability/CVE-2020-5244

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5244/
Summaries are generated and may contain mistakes; the official description above is the record.
