CVE-2020-5247 HTTP Response Splitting in Puma
Attackers can inject malicious content into HTTP responses via newline characters in headers, potentially leading to XSS or cache poisoning.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-5247?
CVE-2020-5247 is a medium-severity vulnerability in Debian Debian Linux, published on 28 Feb 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In Puma (RubyGem) before 4.3.2 and before 3.12.3, if an application using Puma allows untrusted input in a response header, an attacker can use newline characters (i.e. `CR`, `LF` or`/r`, `/n`) to end the header and inject malicious content, such as additional headers or an entirely new response body. This vulnerability is known as HTTP Response Splitting. While not an attack in itself, response splitting is a vector for several other attacks, such as cross-site scripting (XSS). This is related to CVE-2019-16254, which fixed this vulnerability for the WEBrick Ruby web server. This has been fixed in versions 4.3.2 and 3.12.3 by checking all headers for line endings and rejecting headers with those characters.
Which versions are affected by CVE-2020-5247?
6 open source packages ship an affected version, including puma, ruby and ruby-min. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
puma RubyGems | All versions | 3.12.4 |
puma RubyGems | All versions | 3.12.4 |
puma RubyGems | From 4.0.0 | 4.3.3 |
puma RubyGems | From 4.0.0 | 4.3.3 |
ruby Bitnami | All versions | 2.3.1, 2.4.8, 2.5.7, 2.6.5 |
ruby-min Bitnami | All versions | 2.3.1, 2.4.8, 2.5.7, 2.6.5 |
Products include Debian Debian Linux, Fedoraproject Fedora, Puma Puma, Ruby-Lang Ruby.
How do I fix CVE-2020-5247?
Upgrade puma to a fixed version for your release line: 3.12.4 or 4.3.3.
Is CVE-2020-5247 being exploited?
There is no known exploitation of CVE-2020-5247 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-ruby-2020-5247, BIT-ruby-min-2020-5247, DEBIAN-CVE-2020-5247, GHSA-84j7-475p-hp8v.