# CVE-2020-5247: HTTP Response Splitting in Puma

> Attackers can inject malicious content into HTTP responses via newline characters in headers, potentially leading to XSS or cache poisoning.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-ruby-2020-5247, BIT-ruby-min-2020-5247, DEBIAN-CVE-2020-5247, GHSA-84j7-475p-hp8v

## What is CVE-2020-5247?

CVE-2020-5247 is a medium-severity vulnerability in Debian Debian Linux, published on 28 Feb 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Puma (RubyGem) before 4.3.2 and before 3.12.3, if an application using Puma allows untrusted input in a response header, an attacker can use newline characters (i.e. `CR`, `LF` or`/r`, `/n`) to end the header and inject malicious content, such as additional headers or an entirely new response body. This vulnerability is known as HTTP Response Splitting. While not an attack in itself, response splitting is a vector for several other attacks, such as cross-site scripting (XSS). This is related to CVE-2019-16254, which fixed this vulnerability for the WEBrick Ruby web server. This has been fixed in versions 4.3.2 and 3.12.3 by checking all headers for line endings and rejecting headers with those characters.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2020-5247?

6 open source packages ship an affected version, including puma, ruby and ruby-min. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `puma` | RubyGems | All versions | 3.12.4 |
| `puma` | RubyGems | All versions | 3.12.4 |
| `puma` | RubyGems | From 4.0.0 | 4.3.3 |
| `puma` | RubyGems | From 4.0.0 | 4.3.3 |
| `ruby` | Bitnami | All versions | 2.3.1, 2.4.8, 2.5.7, 2.6.5 |
| `ruby-min` | Bitnami | All versions | 2.3.1, 2.4.8, 2.5.7, 2.6.5 |

Products: Debian Debian Linux, Fedoraproject Fedora, Puma Puma, Ruby-Lang Ruby.

## How do I fix CVE-2020-5247?

Upgrade puma to a fixed version for your release line: 3.12.4 or 4.3.3.

## Is CVE-2020-5247 being exploited?

There is no known exploitation of CVE-2020-5247 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5247 and fix it if it is affected.

What it is: CVE-2020-5247 is a medium-severity vulnerability in Debian Debian Linux, published on 28 Feb 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5247 in the wild and no public exploit code.

Affected packages and fixed versions:
- puma (RubyGems): affected all versions; fixed in 3.12.4
- puma (RubyGems): affected all versions; fixed in 3.12.4
- puma (RubyGems): affected from 4.0.0; fixed in 4.3.3
- puma (RubyGems): affected from 4.0.0; fixed in 4.3.3
- ruby (Bitnami): affected all versions; fixed in 2.3.1, 2.4.8, 2.5.7, 2.6.5
- ruby-min (Bitnami): affected all versions; fixed in 2.3.1, 2.4.8, 2.5.7, 2.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5247/ (Markdown: https://insights.sbomify.com/CVE-2020-5247/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5247
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5247
- OSV: https://osv.dev/vulnerability/CVE-2020-5247

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5247/
Summaries are generated and may contain mistakes; the official description above is the record.
