# CVE-2020-5253: Privilege escalation in NetHack


- **Severity:** Low 3.9 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 10 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-5253, GHSA-2c7p-3fj4-223m, UBUNTU-CVE-2020-5253, openSUSE-SU-2025:14898-1

## What is CVE-2020-5253?

CVE-2020-5253 is a low-severity vulnerability in NetHack, published on 10 Mar 2020. 

### Official description

NetHack before version 3.6.0 allowed malicious use of escaping of characters in the configuration file (usually .nethackrc) which could be exploited. This bug is patched in NetHack 3.6.0.

Weakness: CWE-269 (Improper Privilege Management), CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2020-5253?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nethack` | openSUSE:Tumbleweed | All versions | 3.4.3-6.1 |

Products: Nethack Nethack.

## How do I fix CVE-2020-5253?

Upgrade to a fixed version.

## Is CVE-2020-5253 being exploited?

There is no known exploitation of CVE-2020-5253 in the wild and no public exploit code.

## Other vulnerabilities in NetHack

- [CVE-2019-19905](https://insights.sbomify.com/CVE-2019-19905/): Memory corruption in n/a (critical 9.8)
- [CVE-2023-24809](https://insights.sbomify.com/CVE-2023-24809/): NetHack Call command buffer overflow (medium 5.5)
- [CVE-2020-5209](https://insights.sbomify.com/CVE-2020-5209/): NetHack command line parsing of options starting with -de and -i is subject to a buffer overflow (medium 5.0)
- [CVE-2020-5210](https://insights.sbomify.com/CVE-2020-5210/): NetHack command line -w option parsing is subject to a buffer overflow (medium 5.0)
- [CVE-2020-5211](https://insights.sbomify.com/CVE-2020-5211/): NetHack AUTOCOMPLETE configuration file option is subject to a buffer overflow (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5253 and fix it if it is affected.

What it is: CVE-2020-5253 is a low-severity vulnerability in NetHack, published on 10 Mar 2020. 
Exploitation: There is no known exploitation of CVE-2020-5253 in the wild and no public exploit code.

Affected product: NetHack. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5253/ (Markdown: https://insights.sbomify.com/CVE-2020-5253/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5253
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5253
- OSV: https://osv.dev/vulnerability/CVE-2020-5253

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5253/
Summaries are generated and may contain mistakes; the official description above is the record.
