# CVE-2020-5257: Sort order SQL injection in Administrate

> Attackers with dashboard access can inject SQL via the sort direction parameter, potentially reading or modifying database records.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2p5p-m353-833w

## What is CVE-2020-5257?

CVE-2020-5257 is a high-severity SQL injection vulnerability in thoughtbot administrate, published on 13 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Administrate (rubygem) before version 0.13.0, when sorting by attributes on a dashboard, the direction parameter was not validated before being interpolated into the SQL query. This could present a SQL injection if the attacker were able to modify the `direction` parameter and bypass ActiveRecord SQL protections. Whilst this does have a high-impact, to exploit this you need access to the Administrate dashboards, which we would expect to be behind authentication. This is patched in wersion 0.13.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-943 (Improper Neutralization of Special Elements in Data Query Logic)

## Which versions are affected by CVE-2020-5257?

2 open source packages ship an affected version, including administrate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `administrate` | RubyGems | All versions | 0.13.0 |
| `administrate` | RubyGems | All versions | 0.13.0 |

Products: Thoughtbot Administrate.

## How do I fix CVE-2020-5257?

Upgrade administrate to 0.13.0 or later.

## Is CVE-2020-5257 being exploited?

There is no known exploitation of CVE-2020-5257 in the wild and no public exploit code.

## Other vulnerabilities in thoughtbot administrate

- [CVE-2016-3098](https://insights.sbomify.com/CVE-2016-3098/): administrate vulnerable to Cross-Site Request Forgery (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5257 and fix it if it is affected.

What it is: CVE-2020-5257 is a high-severity SQL injection vulnerability in thoughtbot administrate, published on 13 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5257 in the wild and no public exploit code.

Affected packages and fixed versions:
- administrate (RubyGems): affected all versions; fixed in 0.13.0
- administrate (RubyGems): affected all versions; fixed in 0.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5257/ (Markdown: https://insights.sbomify.com/CVE-2020-5257/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5257
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5257
- OSV: https://osv.dev/vulnerability/CVE-2020-5257

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5257/
Summaries are generated and may contain mistakes; the official description above is the record.
