# CVE-2020-5262: GitHub personal access token leaking into temporary EasyBuild (debug) logs

> Attackers with access to debug logs can read GitHub Personal Access Tokens, potentially compromising user accounts.

- **Severity:** High 7.7 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2wx6-wc87-rmjm, PYSEC-2020-268, PYSEC-2020-41

## What is CVE-2020-5262?

CVE-2020-5262 is a high-severity vulnerability in easybuilders easybuild-framework, published on 19 Mar 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In EasyBuild before version 4.1.2, the GitHub Personal Access Token (PAT) used by EasyBuild for the GitHub integration features (like `--new-pr`, `--fro,-pr`, etc.) is shown in plain text in EasyBuild debug log files. This issue is fixed in EasyBuild v4.1.2, and in the `master`+ `develop` branches of the `easybuild-framework` repository.

Weakness: CWE-922 (Insecure Storage of Sensitive Information), CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2020-5262?

4 open source packages ship an affected version, including easybuild-framework and easybuild. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `easybuild-framework` | PyPI | All versions | 4.1.2 |
| `easybuild-framework` | PyPI | All versions | 4.1.2 |
| `easybuild-framework` | PyPI | All versions | 4.1.2 |
| `easybuild` | PyPI | All versions | 4.1.2 |

Products: Easybuild Project Easybuild.

## How do I fix CVE-2020-5262?

Upgrade easybuild-framework to 4.1.2 or later.

## Is CVE-2020-5262 being exploited?

There is no known exploitation of CVE-2020-5262 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5262 and fix it if it is affected.

What it is: CVE-2020-5262 is a high-severity vulnerability in easybuilders easybuild-framework, published on 19 Mar 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-5262 in the wild and no public exploit code.

Affected packages and fixed versions:
- easybuild-framework (PyPI): affected all versions; fixed in 4.1.2
- easybuild-framework (PyPI): affected all versions; fixed in 4.1.2
- easybuild-framework (PyPI): affected all versions; fixed in 4.1.2
- easybuild (PyPI): affected all versions; fixed in 4.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5262/ (Markdown: https://insights.sbomify.com/CVE-2020-5262/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5262
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5262
- OSV: https://osv.dev/vulnerability/CVE-2020-5262

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5262/
Summaries are generated and may contain mistakes; the official description above is the record.
