{"answers":{"affected":"2 open source packages ship an affected version, including auth0-js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-5263 in the wild and no public exploit code.","fix":"Upgrade auth0-js to 9.13.2 or later.","what":"CVE-2020-5263 is a medium-severity vulnerability in auth0.js, published on 9 Apr 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-5263 and fix it if it is affected.\n\nWhat it is: CVE-2020-5263 is a medium-severity vulnerability in auth0.js, published on 9 Apr 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-5263 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0-js (npm): affected from 8.0.0; fixed in 9.13.2\n- auth0-js (npm): affected from 8.0.0; fixed in 9.13.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-5263/ (Markdown: https://insights.sbomify.com/CVE-2020-5263/index.md)","id":"CVE-2020-5263","markdown":"https://insights.sbomify.com/CVE-2020-5263/index.md","name":"CVE-2020-5263","record":{"aliases":["GHSA-prfq-f66g-43mp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"JavaScript authentication library","requires_auth":"high_privilege","summary":"An attacker can obtain plaintext passwords if the application logs or exposes the error object returned by the authentication library during failed login attempts.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"auth0.js","vendor":"auth0"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability. In the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. This is fixed in version 9.12.3","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure through error object","id":"CVE-2020-5263","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"Reflected XSS in security compromised page of PrestaShop","id":"CVE-2020-5264"},"packages":[{"ecosystem":"npm","fixed":["9.13.2"],"introduced":["8.0.0"],"last_affected":[],"package":"auth0-js","purl":null,"source":"GHSA-prfq-f66g-43mp"},{"ecosystem":"npm","fixed":["9.13.2"],"introduced":["8.0.0"],"last_affected":[],"package":"auth0-js","purl":"pkg:npm/auth0-js","source":"GHSA-prfq-f66g-43mp"}],"prev":{"headline":"GitHub personal access token leaking into temporary EasyBuild (debug) logs","id":"CVE-2020-5262"},"products":["auth0.js"],"published":"2020-04-09","related":[{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2018-6873","kev_date_added":null,"published":"2018-04-04"},{"cvss_score":8.8,"headline":"Cross-Site Request Forgery (CSRF) in Auth0","id":"CVE-2018-6874","kev_date_added":null,"published":"2018-04-04"},{"cvss_score":8.8,"headline":"Auth0-js bypasses CSRF checks","id":"CVE-2018-7307","kev_date_added":null,"published":"2018-03-06"},{"cvss_score":7.7,"headline":"Authorization header is not sanitized in an error object in auth0","id":"CVE-2020-15125","kev_date_added":null,"published":"2020-07-29"},{"cvss_score":7.5,"headline":"auth0-js Privilege Escalation Vulnerability","id":"CVE-2017-17068","kev_date_added":null,"published":"2017-12-06"},{"cvss_score":7.1,"headline":"Improper Permission Checking in Auth.js SDK","id":"CVE-2026-42280","kev_date_added":null,"published":"2026-05-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["auth0"]},"summary":"An attacker can obtain plaintext passwords if the application logs or exposes the error object returned by the authentication library during failed login attempts.","url":"https://insights.sbomify.com/CVE-2020-5263/"}