# CVE-2020-5263: Information disclosure through error object

> An attacker can obtain plaintext passwords if the application logs or exposes the error object returned by the authentication library during failed login attempts.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-prfq-f66g-43mp

## What is CVE-2020-5263?

CVE-2020-5263 is a medium-severity vulnerability in auth0.js, published on 9 Apr 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability. In the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. This is fixed in version 9.12.3

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2020-5263?

2 open source packages ship an affected version, including auth0-js. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0-js` | npm | From 8.0.0 | 9.13.2 |
| `auth0-js` | npm | From 8.0.0 | 9.13.2 |

Products: Auth0 Auth0.js.

## How do I fix CVE-2020-5263?

Upgrade auth0-js to 9.13.2 or later.

## Is CVE-2020-5263 being exploited?

There is no known exploitation of CVE-2020-5263 in the wild and no public exploit code.

## Other vulnerabilities in auth0.js

- [CVE-2018-6873](https://insights.sbomify.com/CVE-2018-6873/): Auth bypass in n/a (critical 9.8)
- [CVE-2018-6874](https://insights.sbomify.com/CVE-2018-6874/): Cross-Site Request Forgery (CSRF) in Auth0 (high 8.8)
- [CVE-2018-7307](https://insights.sbomify.com/CVE-2018-7307/): Auth0-js bypasses CSRF checks (high 8.8)
- [CVE-2020-15125](https://insights.sbomify.com/CVE-2020-15125/): Authorization header is not sanitized in an error object in auth0 (high 7.7)
- [CVE-2017-17068](https://insights.sbomify.com/CVE-2017-17068/): auth0-js Privilege Escalation Vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5263 and fix it if it is affected.

What it is: CVE-2020-5263 is a medium-severity vulnerability in auth0.js, published on 9 Apr 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5263 in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0-js (npm): affected from 8.0.0; fixed in 9.13.2
- auth0-js (npm): affected from 8.0.0; fixed in 9.13.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5263/ (Markdown: https://insights.sbomify.com/CVE-2020-5263/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5263
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5263
- OSV: https://osv.dev/vulnerability/CVE-2020-5263

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5263/
Summaries are generated and may contain mistakes; the official description above is the record.
