CVE-2020-5267 Possible XSS vulnerability in ActionView
Attackers can execute arbitrary JavaScript in browsers via XSS in ActionView's JavaScript escape helpers, affecting Ruby on Rails applications.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-5267?
CVE-2020-5267 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 19 Mar 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
In ActionView before versions 6.0.2.2 and 5.2.4.2, there is a possible XSS vulnerability in ActionView's JavaScript literal escape helpers. Views that use the `j` or `escape_javascript` methods may be susceptible to XSS attacks. The issue is fixed in versions 6.0.2.2 and 5.2.4.2.
Which versions are affected by CVE-2020-5267?
4 open source packages ship an affected version, including actionview. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
actionview RubyGems | All versions | 5.2.4.2 |
actionview RubyGems | All versions | 5.2.4.2 |
actionview RubyGems | From 6.0.0 | 6.0.2.2 |
actionview RubyGems | From 6.0.0 | 6.0.2.2 |
Linux distribution packages (6)
rubygem-actionview-5_1 SUSE:Linux Enterprise High Availability Extension 15 | All versions | 5.1.4-3.3.1 |
rubygem-actionview-5_1 SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 5.1.4-3.3.1 |
rubygem-actionview-4_2 SUSE:OpenStack Cloud 7 | All versions | 4.2.9-9.6.1 |
rubygem-actionview-4_2 SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-9.6.1 |
rubygem-actionview-4_2 SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-9.6.1 |
rubygem-actionview-5_1 openSUSE:Leap 15.1 | All versions | 5.1.4-lp151.3.3.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Opensuse Leap, Rubyonrails Actionview.
How do I fix CVE-2020-5267?
Upgrade actionview to a fixed version for your release line: 5.2.4.2 or 6.0.2.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-5267 being exploited?
There is no known exploitation of CVE-2020-5267 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2020-5267, DLA-2149-1, GHSA-65cv-r6x7-79hv, SUSE-SU-2020:0954-1, SUSE-SU-2020:1178-1, UBUNTU-CVE-2020-5267 and 1 more.