# CVE-2020-5268: Subject Confirmation Method not validated in Saml2 Authentication Services for ASP.NET

> Attackers can bypass authentication by using SAML2 tokens with non-bearer confirmation methods, allowing unauthorized session creation.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9475-xg6m-j7pw

## What is CVE-2020-5268?

CVE-2020-5268 is a medium-severity authentication bypass vulnerability in Sustainsys Saml2, published on 21 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In Saml2 Authentication Services for ASP.NET versions before 1.0.2, and between 2.0.0 and 2.6.0, there is a vulnerability in how tokens are validated in some cases. Saml2 tokens are usually used as bearer tokens - a caller that presents a token is assumed to be the subject of the token. There is also support in the Saml2 protocol for issuing tokens that is tied to a subject through other means, e.g. holder-of-key where possession of a private key must be proved. The Sustainsys.Saml2 library incorrectly treats all incoming tokens as bearer tokens, even though they have another subject confirmation method specified. This could be used by an attacker that could get access to Saml2 tokens with another subject confirmation method than bearer. The attacker could then use such a token to create a log in session. This vulnerability is patched in versions 1.0.2 and 2.7.0.

Weakness: CWE-287 (Improper Authentication), CWE-303 (Incorrect Implementation of Authentication Algorithm)

## Which versions are affected by CVE-2020-5268?

4 open source packages ship an affected version, including Sustainsys.Saml2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Sustainsys.Saml2` | NuGet | All versions | 1.0.2 |
| `Sustainsys.Saml2` | NuGet | All versions | 1.0.2 |
| `Sustainsys.Saml2` | NuGet | From 2.0.0 | 2.7.0 |
| `Sustainsys.Saml2` | NuGet | From 2.0.0 | 2.7.0 |

Products: Sustainsys Saml2.

## How do I fix CVE-2020-5268?

Upgrade Sustainsys.Saml2 to a fixed version for your release line: 1.0.2 or 2.7.0.

## Is CVE-2020-5268 being exploited?

There is no known exploitation of CVE-2020-5268 in the wild and no public exploit code.

## Other vulnerabilities in Sustainsys Saml2

- [CVE-2020-5261](https://insights.sbomify.com/CVE-2020-5261/): Missing Token Replay Detection (high 8.2)
- [CVE-2023-41890](https://insights.sbomify.com/CVE-2023-41890/): Sustainsys.Saml2 Insufficient Identity Provider Issuer Validation (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-5268 and fix it if it is affected.

What it is: CVE-2020-5268 is a medium-severity authentication bypass vulnerability in Sustainsys Saml2, published on 21 Apr 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-5268 in the wild and no public exploit code.

Affected packages and fixed versions:
- Sustainsys.Saml2 (NuGet): affected all versions; fixed in 1.0.2
- Sustainsys.Saml2 (NuGet): affected all versions; fixed in 1.0.2
- Sustainsys.Saml2 (NuGet): affected from 2.0.0; fixed in 2.7.0
- Sustainsys.Saml2 (NuGet): affected from 2.0.0; fixed in 2.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-5268/ (Markdown: https://insights.sbomify.com/CVE-2020-5268/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-5268
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-5268
- OSV: https://osv.dev/vulnerability/CVE-2020-5268

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-5268/
Summaries are generated and may contain mistakes; the official description above is the record.
